原创:数据中心零down机时间的迁移方案分享 作者肖建秋

来源:本站原创 网络技术 超过657 views围观 0条评论

机房要搬,很多服务器和网络设备都是冗余设计的。 为了减少down机时间:
1. 在原机房继续提供服务的情况下,先迁一部分冗余的服务器和网络设备到新机房。
2. 在新老机房间租条专线,保证迁移过程中的两机房间的通讯需要
3. 把迁到新机房的设备安装好,运行起来,确保能够正常提供服务后,再迁老机房剩下的设备
这样理论上可以实现零down机时间的迁移。
问题是,迁到新机房的服务器的IP地址,网络设备的VLAN信息等都需要保留。要暂时被分为两部分的数据中心,看起来如同一个整体。
我们使用l2tpv3来做
clip_image001
上图左侧为现有机房,右侧为新机房;在两机房间,我们使用两个路由器l2tp1和l2tp2,通过租用的专线连接,在上面建立layer 2 tunnel,传递vlan信息等二层数据.
l2tp1 running-config:
l2tp-class DC1
hello 10
password 7 1511021F0725
cookie size 8
!
pseudowire-class dmz
encapsulation l2tpv3
protocol l2tpv3 DC1
ip local interface Loopback0
ip dfbit set
!
pseudowire-class intra
encapsulation l2tpv3
protocol l2tpv3 DC1
ip local interface Loopback1
ip dfbit set
!
interface Loopback0
descript  **dmz l2tp local int**
ip address 10.1.1.1 255.255.255.255
!
interface Loopback1
descript  **intranet l2tp local int**
ip address 10.1.1.3 255.255.255.255
!
interface FastEthernet0/0
descript ** to dmz switch**
no ip address
no cdp enable
xconnect 10.1.1.2 12 encapsulation l2tpv3 pw-class dmz
!
interface FastEthernet0/1
descript ** to intranet switch **
no ip address
no cdp enable
xconnect 10.1.1.4 13 encapsulation l2tpv3 pw-class intra
!
interface FastEthernet1/0
descript ** to new data center router **
ip address 10.1.1.97 255.255.255.224
!
ip route 10.1.1.2 255.255.255.255 10.1.1.98
ip route 10.1.1.4 255.255.255.255 10.1.1.98
l2tp2 running-config:
l2tp-class DC2
hello 10
password 7 1511021F0725
cookie size 8
!
pseudowire-class dmz
encapsulation l2tpv3
protocol l2tpv3 DC2
ip local interface Loopback0
ip dfbit set
!
pseudowire-class intra
encapsulation l2tpv3
protocol l2tpv3 DC2
ip local interface Loopback1
ip dfbit set
!
interface Loopback0
descript  **dmz l2tp local int**
ip address 10.1.1.2 255.255.255.255
!
interface Loopback1
descript  **intranet l2tp local int**
ip address 10.1.1.4 255.255.255.255
!
interface FastEthernet0/0
descript ** to dmz switch**
no ip address
no cdp enable
xconnect 10.1.1.1 12 encapsulation l2tpv3 pw-class dmz
!
interface FastEthernet0/1
descript ** to intranet switch **
no ip address
no cdp enable
xconnect 10.1.1.3 13 encapsulation l2tpv3 pw-class intra
!
interface FastEthernet1/0
descript ** to orig data center router **
ip address 10.1.1.98 255.255.255.224
!
ip route 10.1.1.1 255.255.255.255 10.1.1.97
ip route 10.1.1.3 255.255.255.255 10.1.1.97
这样配置完后,l2tp1和l2tp路由器对于两侧的交换设备来说就好像不存在,两侧DMZ和INTRANET区域中的交换机互为cdp neighbor, 共享VLAN信息,二层互通。
另外,如果您感觉在租用的专线上有加密的必要,那么还可以在l2tp1和l2tp2之间启用ipsec vpn, 做一个 l2tp over ipsec。 如果是这样,您需要了解l2tp使用的协议是ip 115, 也就是说在定义ipsec感兴趣的流量时,要这样写:
在l2tp1上:
permit 115 host 10.1.1.1 host 10.1.1.2
permit 115 host 10.1.1.3 hst 10.1.1.4
在l2tp2上:
permit 115 host 10.1.1.2 host 10.1.1.1
permit 115 host 10.1.1.4 host 10.1.1.3

文章出自:CCIE那点事 http://www.jdccie.com/ 版权所有。本站文章除注明出处外,皆为作者原创文章,可自由引用,但请注明来源。 禁止全文转载。
本文链接:http://www.jdccie.com/?p=1833转载请注明转自CCIE那点事
如果喜欢:点此订阅本站