关于PPP Multilink协议的配置

来源:本站原创 网络技术 超过1,661 views围观 0条评论

使用2个E1捆绑实现4M的数据传输,现把文档写出来供大家参考。

PPP Multilink协议(MP)是PPP(点对点协议)的扩展,它具有绑定两条或多条同步并行连接的能力。所产生的虚拟连接拥有的带宽等于各条独立连接的带宽的总和。 PPP包含有用来重组和排序的信息。 MP在需要时可以把包切割成碎片(fragment)以符合MTU(最大传输单元)的值,或者也可选择把整个包发送到可用的链路上。MP沿着首选的可用链路传输每一个单独的包或碎片,附带有额外的信息,以使接受端可以把这些碎片重新组合成单个包,再进行路由转发。 MP是包含绑定的带宽整合的一种形式,它是RFC 1990.MP所定义的非专有TCP/IP标准的一个组成部分。工作原理 PPP Multilink把单个PPP连接分割为两条独立的物理链路,然后以正确的顺序重新组合它们。要实现这一点的话必须在链路的两端都有一个遵从MP协议的硬件设备或软件程序。MP是这样来执行以上功能的: l 源端的MP收到数据包 l 把它们切割成碎片(可选) l 决定下一条可用的链路 l 添加一个包含顺序号和其它信息的PPP Multilink包头 l 把数据包或碎片转发到可用的链路上 l 接受端的MP收到数据包或数据包碎片 l 移去MP包头 l 重新把碎片组合成完整的包 l 转发数据包到相应的IP地址结果是,不管这些链路在容量上有多大的差别,也不管可用带宽浮动得多么厉害,也能在可用的链路上平滑地分配流量。主要优势 PPP Multilink的主要优势在于:它是公开的标准,因此至少在理论上提供了跨厂商的协同工作能力和兼容性。甚至对于单条TCP/IP连接也同样具有优势,例如一个FTP下载,就能够从多链路中得到好处。假如你透过绑定两条链路的一个PPP Multilink连接下载一个文件,下载的速度将会快两倍。不管是FTP客户端还是服务器端都不会知道中间是一个多链路的连接。简单来说,由于PPP Multilink是透明的协议,任何在主机和客户端之间使用单连接的协议,例如终端仿真,都将从多链路所提供的带宽整合中得益。

3.2 网络具体配置甲地cisco3640路由器:

 

dyjrtlo(config)#controller e1 3/0

dyjrtlo(config-controller)#framing no-crc4

dyjrtlo(config-controller)#linecode hdb3

dyjrtlo(config-controller)#channel-group 0 timeslots 1-31

dyjrtlo(config-controller)#exit

dyjrtlo(config)#controller e1 3/1

dyjrtlo(config-controller)#framing no-crc4

dyjrtlo(config-controller)#linecode hdb3

dyjrtlo(config-controller)#channel-group 0 timeslots 1-31

dyjrtlo(config-controller)#exit

dyjrtlo(config)#interface multilink 1

dyjrtlo(config-if)#ip address 132.100.19.70 255.255.255.252

dyjrtlo(config-if)#ppp multilink

dyjrtlo(config-if)#multilink-group 1

dyjrtlo(config-if)#no ppp multilink fragmentation

dyjrtlo(config-if)#ip access-group 101 in

dyjrtlo(config-if)#exit

dyjrtlo(config)#interface s 3/0:0

dyjrtlo(config-if)#no ip address

dyjrtlo(config-if)#no ip access-group 101 in

dyjrtlo(config-if)#encapsulation ppp

dyjrtlo(config-if)#ppp multilink

dyjrtlo(config-if)#multilink-group 1

dyjrtlo(config-if)#exit

dyjrtlo(config)#interface s 3/1:0

dyjrtlo(config-if)#no ip address

dyjrtlo(config-if)#encapsulation ppp

dyjrtlo(config-if)#ppp multilink

dyjrtlo(config-if)#multilink-group 1

dyjrtlo(config-if)#exit dyjrtlo#wr

乙地OMC机房cisco3640路由器:

dzjrt1o(config)#controller e1 0/1

dzjrt1o(config-controller)#framing no-crc4

dzjrt1o(config-controller)#linecode hdb3

dzjrt1o(config-controller)#channel-group 0 timeslots 1-31

dzjrt1o(config-controller)#exit

dzjrt1o(config)#controller e1 2/1

dzjrt1o(config-controller)#framing no-crc4

dzjrt1o(config-controller)#linecode hdb3

dzjrt1o(config-controller)#channel-group 0 timeslots 1-31

dzjrt1o(config-controller)#exit

dzjrtlo(config)#interface multilink 1

dzjrtlo(config-if)#ip address 132.100.19.69 255.255.255.252

dzjrtlo(config-if)#ppp multilink

dzjrtlo(config-if)#multilink-group 1

dzjrtlo(config-if)#no ppp multilink fragmentation

dzjrtlo(config-if)#ip access-group 101 in

dzjrtlo(config-if)#exit

dzjrtlo(config)#interface s 2/1:0

dzjrtlo(config-if)#no ip address

dzjrtlo(config-if)#no ip access-group 101 in

dzjrtlo(config-if)#encapsulation ppp

dzjrtlo(config-if)#ppp multilink

dzjrtlo(config-if)#multilink-group 1

dzjrtlo(config-if)#exit

dzjrtlo(config)#interface s 0/1:0

dzjrtlo(config-if)#no ip address

dzjrtlo(config-if)#encapsulation ppp

dzjrtlo(config-if)#ppp multilink

dzjrtlo(config-if)#multilink-group 1

dzjrtlo(config-if)#exit dzjrtlo#wr

文章出自:CCIE那点事 http://www.jdccie.com/ 版权所有。本站文章除注明出处外,皆为作者原创文章,可自由引用,但请注明来源。 禁止全文转载。
本文链接:http://www.jdccie.com/?p=223转载请注明转自CCIE那点事
如果喜欢:点此订阅本站
  • 相关文章
  • 为您推荐
  • 各种观点

暂时还木有人评论,坐等沙发!
发表评论

您必须 [ 登录 ] 才能发表留言!