cisco2811语音网关+callmanager拨打外线,外线拨入详解配置

来源:本站原创 Voice 超过1,336 views围观 0条评论

cisco2811语音网关+callmanager拨打外线,外线拨入详解配置
——————包括AA和连接PBX的配置 这是我们公司内部的IP语音网络环境,忙活了好几天总算弄明白了。 基本拓扑图如下:

 

http://img.bimg.126.net/photo/DoR6c1OuGieMtON3r7wuDg==/449234062847054745.jpg
A.首先要在callmanager上进行h.323和router pattern的简单配置 B.下面是在CISCO2811路由器上的配置—-此路由上安装了一个4FXO口的语音模块 1.下面是AA的配置: application
service aa flash:its-CISCO.2.0.1.0.tcl //调用TCL脚本,定义服务名字为aa(Auto Attendant)
paramspace english language en/定义语言为英文,这个无所谓,反正你播放的是中文的welcome.au就可以了
paramspace english index 1//定义索引位置
param operator 888                          //设置人工总机为888
paramspace english location flash:
param aa-pilot 678                      //设置自动话务员的号码,这个随便设
param welcome-prompt en_welcome.au      //设置提示音,自己录制时注意格式.au,8-bit,8kHZ,u-law 各音频文件名与系统自带的文件名一致,重启路由器 2.在接口上的配置: interface Loopback0     //为了使本地可以拨打AA自动话务员,需要配置这个地址
ip address 1.1.1.1 255.255.255.0 //此地址随意
!
interface FastEthernet0/0
ip address 121.29.221.138 255.255.255.0
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
crypto map mymap //将保密映射应用到接口上,指定要使用的加密图
!
interface FastEthernet0/1
ip address 192.168.100.3 255.255.255.0
ip nbar protocol-discovery
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
h323-gateway voip interface 3.voice-port的配置: voice-port 0/0/0    //进入语音端口FXO配置模式
cptone CN          //配置铃音使用中国制式
timeouts call-disconnect 1
timeouts wait-release 1     //定义呼叫、等待时间
!
voice-port 0/0/1             //此端口连接PSTN
supervisory disconnect dualtone mid-call
cptone CN
timeouts call-disconnect 1
timeouts wait-release 1
caller-id enable
!
voice-port 0/0/2             //此端口连接PSTN
supervisory disconnect dualtone mid-call//配置Tone管理断开——主要是外线拨打IP电话时,不能及时挂断的方法
cptone CN
timeouts call-disconnect 1//呼叫中断的超时设定
timeouts wait-release 1//等待释放的超时设定
!
voice-port 0/0/3             //此端口连接PBX的FXS口
supervisory disconnect dualtone mid-call
cptone CN
timeouts call-disconnect 1
timeouts wait-release 1 4.拨打外线的配置: dial-peer voice 2 pots //配置一个POTS拨号对等体(和配置静态路由时的ip route命令类似)
service aa
destination-pattern 9T//表示9+电话号码,即拨出的电话号码,表示号码前加入9才能通过这个端口出局
incoming called-number .
port 0/0/1   ////指定端口(FXO口0/0/1)
!
dial-peer voice 4 pots
service aa
destination-pattern 9T
incoming called-number .
port 0/0/2
!
dial-peer voice 200 pots
service aa
destination-pattern .T //.表示一个任意数字,T表示多个任意数字
port 0/0/3 5.外线拨入和PBX上模拟电话拨打IP电话的配置: dial-peer voice 344 voip//配置一个VOIP拨号对等体
destination-pattern 6..//内部IP分机
session target ipv4:192.168.100.209//会话目标IP(和配置静态路由时的下一跳地址类似)
dtmf-relay h245-alphanumeric//DTMF使用h245-alphanumeric,写错了就无法输入分机号码了
codec g711ulaw   //强制使用G.711ulaw,否则容易因为codec出问题
no vad           //关闭VAD,否则容易出毛病
!
dial-peer voice 345 voip
destination-pattern 5..
session target ipv4:192.168.100.209
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 300 voip   //配置与实验室2811CME的电话互通
destination-pattern 4..
session target ipv4:192.168.100.11 //实验室2811的F0/1接口地址
!
dial-peer voice 10 voip
service aa
destination-pattern 678   //使本地可以拨打自动话务员,必须配合下面的session
session target ipv4:1.1.1.1//
incoming called-number 678 //配置拨入的电话为678的时候,才调用server aa
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad

本文出自 “小鱼的理想” 博客,请务必保留此出处http://yushuicheng.blog.51cto.com/406234/150808

文章出自:CCIE那点事 http://www.jdccie.com/ 版权所有。本站文章除注明出处外,皆为作者原创文章,可自由引用,但请注明来源。 禁止全文转载。
本文链接:http://www.jdccie.com/?p=286转载请注明转自CCIE那点事
如果喜欢:点此订阅本站
  • 相关文章
  • 为您推荐
  • 各种观点

暂时还木有人评论,坐等沙发!
发表评论

您必须 [ 登录 ] 才能发表留言!