思科rip技术详解

来源:本站原创 网络技术详解 超过2,051 views围观 0条评论

RIP

介绍:RIP协议的处理是通过UDP 520端口来操作的,所有的RIP消息都被封装在UDP数据报文中,其中数据报文的源和目的端口字段被设置为520。RIP定义了两种消息类型:请求消息(request messages)和响应消息(response messages)请求消息用来向邻居路由器发送一个更新,响应消息用来传路由更新。RIP的度量是基于“跳数”的,1跳表示的是与发出通告的路由器相直连的网络,16跳表示网络不可到达。

工作原理:开始时,RIP从每个启动RIP协议的接口广播出带有请求消息的数据包,接着,RIP程序进入一个循环状态,不断地监听来自其他的路由器的RIP请求或响应消息,而接收请求的邻居路由器则回送包含它们的路由表的响应消息。当发出请求的路由收到响应消息时,它将开始处理附加在响应消息中的路由更新信息,如果路由更新中的路由条目是新的,路由器则将新的路由连同通告路由器的地址一起加入到自己的路由选择表中,这里通告路由器的 地址可以从更新数据包的源地址字段读出如果网络路由已经在路由选择表中存在,那么只有在新的路由拥有更小的跳数据时才能替换原来存在的路由条目。如果路由更新通告的跳数大于路由选择表已记录的跳数,并且更新来自于已记录条目的下一跳路由器,那么该路由将在一个指定的抑制时间段(hold down period)内被标记为不可到达,如果在抑制时间超时后,同一个邻居路由器仍然通告这个有较大跳数的路由,路由器则接受该路由新的度量值。

计时器和稳定性:

1,Update time 缺省是30s 异步更新为25—35 同步更新为25–30

2,Invalid time(无效计时器) 180s 如果3次都没有收到update 路由条目down 还可以转发数据包的

3,Flush 240s Invalid 180s 后,再过60s(这60s是在发3次毒性路由)删除路由条目

4,Hold time 180s 收到的路由条目比原来的路由条目METRIC值大我不更新我的路由条目等待180s中 如果又收到路由条目就更新

RIP使用带毒性逆转,水平分隔和触发更新,不像普通的定期的更新,触发更新在只要有路由的度量值发生改变时就会产生,而且触发更新不会引起接收路由器重置综们的更新计时器;因为如果这么做的话,网络拓扑的改变会导致很多路由器在同一时间重置,从而引起定其的路由更新变得同步。为了避免拓扑改变后造成触发更新“风暴”,还需要使用另外一个计时器。当一个触发更新传播时,这个计时器被随机的设置为1~5s之间的数值;在这个计时器计时超过前不能发送并发的触发更新。

一些主机可以在“静”模式下使用RIP,这些所谓的“静”主机不产生RIP的更新报文,而只侦听RIP的更新消息,从而更新它们自己的路由选择表。

RIP的消息格式(RIP message format)RIPv1

RIP消息头部(4个字节),每个条目占用20个字(最多可以容纳25条),8个字节的UDP头部,所以RIP数据报文的大小最大可达512个字节

命令(command)—-只取值1或2,1表示是请求消息,2 表示是响应消息,其他取值都不被使用或保留作私有用途。

版本号(version)—-对于RIPv1,该字段的值设置为1。

地址族标识(address family identifier, AFI)—-对于IP该项设置为2,只有一个例外情况下该消息是路由器(或主机)整个路由选择表的请求。

IP地址(IP address)—-路由的目的地址,这一项可以是主网络地址,子网地址或主机路由地址。

度量(metric)—-跳数1~16

RIP的消息格式(RIP message format)RIPv2

RIPv1有的RIPv2都有,在RIPv1的基础上加了以下这些:

路由标志(route tag)—-提供这个字段用来标记外部路由或重分配到RIPv2协议中的路由,默认的情况下是使用这个16位的字段来携带从外部路由选择协议注入到RIP中的路由的自主系统号。

下一跳(next top)—–如果存在的话,它标识一个比通告路由器地址更好的下一跳地址。

有类别路由选择

它的一个基本特性就是,宣告网络地址的时候不能把它的掩码也宣告出去,因此,有类别路由选择协议首先必须匹配一个目的地址对应A,B,C类的主网络号,对于每一个通过路由器的数据包:1,如果目的地址是一个路由器直接相连的主网络的成员,那么该网络的路由器接口上配置的子网掩码将被用来确定目的的地址的子网,因此,在那个主网络中必须自始至终地统一使用这个相同的子网掩码。2,如果目的地址不是一个和路由器直接相连的主网络的成员,那么路由器将仅仅尝试去匹配该目的的地址对应于A类,B类或C类的主网络号。

被动接口:

被动接口就是一个RIP网络中有一个路由器1启用了RIP协议,而它没有把接口地址宣告进去,但是它还是能更新自己的路由表,但是这个接口会向直连它的路由器2发广播包,为了阻塞广播包可以在路由器2的RIP协议下加上这条命令:passive-interface。这样就可以把这个路由器1做为一个“静”主机看待,不发路由更新,只侦听特定的链路上的RIP广播,从而更新自己的路由表。

命令:

R1(config-router)#neighbor 192.168.10.2 手动配置邻居,在路由器是“静”主机的情况下,可以交换RIP通告信息

R1#debug ip rip events 简要地显示路由器收发的RIP信息。

特点:

交换是自已的路由表,全部路由条目

负载均衡最多支持6条,默认的是4条

自动汇总默认的是开着的

RIPv1 (有类路由协议)

网络号

METRIC

下一跳 数据包的源IP

广播地址:255.255.255.255

自动汇总,不支持手动汇总

不支持认证

不支持VLMS产生CIDR

RIPv2(无类路由协议)

网络号

METRIC

子网掩码 (无类路由协议)不产生CIDR

下一跳 (0.0.0.0 —>数据包的源IP)

组播地址:224.0.0.9

支持手工汇总

支持认证

RIPv2和RIPv1 兼容性

RIPv2的报文在RIPv1中不能识别,会被丢弃,而RIPv1的报文在RIPv2中可以识别。RIPv2在RIPv1中使用RIPv2使用广播方式代替组播方式来通告消息,以便RIPv1可以接收它们。RIPv2在RIPv2中使用组播方式通告消息到目的地址224.0.0.9。

RIP的不足之处:

(1)过于简单,以跳数为依据计算度量值,经常得出非最优路由。例如:2跳64K专线,和3跳1000M光纤,显然多跳一下没什么不好。

(2)度量值以16为限,不适合大的网络。解决路由环路问题,16跳在rip中被认为是无穷大,rip是一种域内路由算法自治路由算法,多用于园区网和企业网。

(3)安全性差,接受来自任何设备的路由更新。无密码验证机制,默认接受任何地方任何设备的路由更行。不能防止恶意的rip欺骗。

(4)不支持无类ip地址和VLSM<ripv1>。

(5)收敛性差,时间经常大于5分钟。

(6)消耗带宽很大。完整的复制路由表,把自己的路由表复制给所有邻居,尤其在低速广域网链路上更以显式的全量更新。

配置:

实验目的:让所有路由器上的环回口通过运行RIP协议可以互相通信。

R1(config)#int f0/0

R1(config-if)#ip address 192.168.12.1 255.255.255.0

R1(config-if)#no shut

R1(config)#int lo 0 创建环回口

R1(config-if)#ip address 1.1.1.1 255.255.255.255

R1(config)#router rip 创建RIP协议

R1(config-router)#version 2 版本号为2

R1(config-router)#no auto-summary 关闭自动汇总

R1(config-router)#network 192.168.12.0 地址宣告进RIP

R2(config)#int f0/0

R2(config-if)#ip address 192.168.22.1 255.255.255.0

R2(config-if)#no shut

R2(config)#int lo 0 创建环回口

R2(config-if)#ip address 2.2.2.2 255.255.255.255

R2(config)#router rip 创建RIP协议

R2(config-router)#version 2 版本号为2

R2(config-router)#no auto-summary 关闭自动汇总

R2(config-router)#network 192.168.22.0 地址宣告进RIP

R3(config)#int f0/0

R3(config-if)#ip address 192.168.32.1 255.255.255.0

R3(config-if)#no shut

R3(config)#int lo 0 创建环回口

R3(config-if)#ip address 3.3.3.3 255.255.255.255

R3(config)#router rip 创建RIP协议

R3(config-router)#version 2 版本号为2

R3(config-router)#no auto-summary 关闭自动汇总

R3(config-router)#network 192.168.32.0 地址宣告进RIP

R4(config)#int f0/0

R4(config-if)#ip address 192.168.12.2 255.255.255.0

R4(config-if)#no shut

R4(config-if)#int f1/0

R4(config-if)#ip address 192.168.22.2 255.255.255.0

R4(config-if)#no shut

R4(config-if)#int f2/0

R4(config-if)#ip address 192.168.32.2 255.255.255.0

R4(config-if)#no shutR4(config)#router rip 创建RIP协议

R4(config-router)#version 2 版本号为2

R4(config-router)#no auto-summary 关闭自动汇总

R4(config-router)#network 192.168.12.0 地址宣告进RIP

R4(config-router)#network 192.168.22.0 地址宣告进RIP

R4(config-router)#network 192.168.32.0 地址宣告进RIP

扩展命令:

R1(config)#show ip rip da 查看rip database (从邻居收集来的信息)的

R1(config)#no auto-summary 关闭自动汇总

R1(config)#show run | s rip 查看RIP配置

R1(config)#Show ip rout 查看路由表

R1(config-if)#ip rip send version 2 指定一个接口可以发送的RIP的版本

R1(config-if)#ip subnet-zero 允许接口的地址和路由选择更新使用全0子网

R1(config)#interface serial 0/0

R1(config-if)#ip summary-address rip 10.0.0.0 255.0.0.0 手动开始汇总

R1(config)#key chain cisco 定义rip中加密密钥链

R1(config-keychain)#key 0 定义密钥

R1(config-keychain-key)#key-string cisco 定义密钥值

R1(config-if)#ip rip authentication key-chain cisco 在接口上调用密钥

R1(config-if)#ip rip authentication mode text 选择加密方式 明文

R1(config-if)#ip rip authentication mode md5 选择加密方式 密文

文章出自:CCIE那点事 http://www.jdccie.com/ 版权所有。本站文章除注明出处外,皆为作者原创文章,可自由引用,但请注明来源。 禁止全文转载。
本文标题:思科rip技术详解
本文链接:http://www.jdccie.com/?p=3042转载请注明转自CCIE那点事
如果喜欢:点此订阅本站
上篇文章:
下篇文章: