思科BFD协议帮助侦测网络失败

来源:本站原创 网络技术 超过2,491 views围观 0条评论

Bidirectional Forwarding Detection (BFD) 顾名思义为双向侦测协议,只检测与下一跳设备设备连接状态。目前只在7200以上系列路由器千兆以太接口以上支持,并支持OSPF、ERGRP、ISIS、BGP协议。当客户端协议建立后,将告诉BFD协议去检测邻接连接状态。BFD检测包在CEF中具有高的优先级,并且通过unicast形式相互传播。
FIGURE 1 When OSPF discovers a neighbor (step 1) it sends a request to the local BFD process to initiate a BFD neighbor session with the OSPF neighbor router (step 2). The BFD neighbor session with the OSPF neighbor router is established (step 3).
FIGURE 2 When a failure occurs in the network (step 1), the BFD neighbor session with the OSPF neighbor router is torn down (step 2). BFD notifies the local OSPF process that the BFD neighbor is no longer reachable (step 3). The local OSPF process tears down the OSPF neighbor relationship (step 4)
配置

可以应用到所有接口上
router ospf 1

[no] bfd all-interfaces
也可以应用在单个接口上
[no] ip ospf bfd [disable]



例子
Configuration for Router A

interface Ethernet2/0

ip address 172.16.10.1 255.255.0.0

bfd interval 50 min_rx 50 multiplier 3

!

router ospf 1

log-adjacency-changes detail

network 172.16.0.0 0.0.255.255 area 0

bfd all-interfaces

Configuration for Router B

interface Ethernet1/0

ip address 172.16.10.2 255.255.0.0

bfd interval 50 min_rx 50 multiplier 3

!

router ospf 1

log-adjacency-changes detail

network 172.16.0.0 0.0.255.255 area 0

bfd all-interfaces

显示本地状态
RouterA#sh ip ospf int e2/0

Ethernet2/0 is up, line protocol is up

Internet Address 172.16.10.1/16, Area 0
Process ID 1, Router ID 172.16.10.1, Network Type BROADCAST, Cost: 10

Transmit Delay is 1 sec, State BDR, Priority 1,BFD enabled

Designated Router (ID) 172.16.10.2, Interface address 172.16.10.2

Backup Designated router (ID) 172.16.10.1,Interface address 172.16.10.1

Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

查看邻居状态 show ip ospf neighbor
RouterA#sh ip ospf nei 172.16.10.2 det

Neighbor 172.16.10.2, interface address 172.16.10.2

In the area 0 via interface Ethernet2/0, BFD enabled

Neighbor priority is 1, State is FULL, 6 state changes

文章出自:CCIE那点事 http://www.jdccie.com/ 版权所有。本站文章除注明出处外,皆为作者原创文章,可自由引用,但请注明来源。 禁止全文转载。
本文链接:http://www.jdccie.com/?p=308转载请注明转自CCIE那点事
如果喜欢:点此订阅本站
  • 相关文章
  • 为您推荐
  • 各种观点

暂时还木有人评论,坐等沙发!
发表评论

您必须 [ 登录 ] 才能发表留言!