CISCO寄存器值及调试

来源:本站原创 CISCO 超过903 views围观 0条评论

Cisco路由器的内部组件

1.       bootstrap

2.       post

3.       ROM

4.       小型IOS

5.       RAM

6.       ROM

7.       NVRAM

8.       Configuration register

路由器启动顺序

启动顺序包括下列步骤

1.  路由器执行POST。

2.  Bootstrap查找并加载Cisco IOS软件。

3.  IOS软件在NVRAM中查找有效的配置文件。

4.  如果NVRAM中有startup-config文件,路由器将加载并运行此文件。

管理配置寄存器

所有Cisco路由器都具有一个位于NVRAM中的16位软件寄存器。默认情况下,配置寄存器设置为从闪存加载startup-config文件。

理解配置寄存器位

配置寄存器的16位从左到右是从15读到0。Cisco路由器默认的配置设置时0x2102。

软件配置意义


十六进制
解释
0-3
0x0000-0x000f
启动字段
6
0x0040
忽略NVRAM内容
7
0x0080
启用OEM位
8
0x101
禁用中断
10
0x0400
IP广播全为零
5、11-12
0x0800-0x1000
控制台线路速率
13
0x2000
如果网络启动实效则启动默认ROM软件
14
0x4000
IP广播包含网络号
15
0x8000
启用诊断信息并忽略NVRAM内容

位于配置寄存器0位-3位的启动字段控制路由器的启动顺序。

检查当前配置寄存器值

使用show version命令可以查看配置寄存器的当前值。

Cisco Internetwork Operating System Software

IOS ™ 2500 Software (C2500-JS56I-L), Version 12.1(5)T12,  RELEASE SOFTWARE (fc1)

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2002 by cisco Systems, Inc.

(略)

Configuration register is 0x2142

命令最后给出的信息就是配置寄存器的值。

修改配置寄存器的值

可以通过修改配置寄存器的值来修改路由器如何启动和运行。

下面是修改配置寄存器的可能原因:

1.  强制系统进入ROM监控模式

2.  选择启动来源和默认的启动文件名

3.  启用或禁用Break(中断)功能

4.  控制广播地址

5.  设置控制台中断波特率

6.  从ROM加载操作软件

7.  启用从TFTP启动服务器

使用config-register命令修改配置寄存器。

下面命令告诉路由器忽略NVRAM内容:

Router(config)#config-register 0x2142

Router(config)#^Z

Router#sh ver

(略)

Configuration register is 0x2142

恢复口令

如果忘记了口令,可以通过修改寄存器的值来进行恢复。

默认的配置寄存器值是0x2102,在默认情况下,路由器会查找并加载存储在NVRAM中的路由器配置。现在我们要更改值,让路由器忽略NVRAM的内容。

这里是口令恢复的主要步骤:

1.  启动路由器并通过执行一个中断来中断启动顺序

2.  修改配置寄存器开启第6位(值为0x2142)

3.  重载路由器

4.  进入特权模式。

5.  将startup-config文件复制为running-config文件

6.  修改口令

7.  将配置寄存器重设为默认值

8.  保存路由器的配置

9.  重载路由器。

下面是详细步骤:

中断路由器启动顺序

做法是,当路由器第一次启动时同时按下CTRL+BREAK组和键来执行一个中断。

修改配置寄存器

2600系列命令

Rommon 1> confreg 0x2142

2500系列命令

>o/r 0x2142

从载路由器进入特权模式

再此情况下,需要像下面这样从蛇路由器:

2600系列上,输入reset

2500系列上,输入I(初始化)

查看并修改配置

将startup-config文件复制到running-config文件

Copy startup-config running-config

缩写 copy start run

但是不能查看secret设置的口令。要修改口令,这样做

Config t

Enable secret 12345

重设配置寄存器并重载路由器

使用config-register命令将配置寄存器设置回默认值:

Config t

Config-register 0x2102

最后使用Copy run start 命令保存配置并重载路由器。

备份和恢复Cisco IOS

在省级或恢复Cisco IOS之前,应当将已有文件复制到TFTP主机作为备份,以防止新的影响文件不能正常运行。

在将IOS映像文件备份到网络服务器之前,完成下列操作:

1.  确定可以访问网络服务器。

2.  确保网络服务器对于影响文件具有足够的空间。

3.  验证所需的文件名以及路径。

验证闪存

当场是在路由器上用心的IOS文件升级Cisco IOS之前,应当验证闪存具有充足的空间来保存新的映像文件。可以使用sh flash命令验证闪存的容量和姚存储到闪存中文件的大小:

Router#sh flash

System flash directory:

File  Length   Name/status

  1   16082856  c2500-js56i-l.121-5.T12.bin 

[16082920 bytes used, 694296 available, 16777216 total]

16384K bytes of processor board System flash (Read ONLY)

这里文件名是c2500-js56i-l.121-5.T12.bin。这个文件名称具有平台特性,名称来源如下:

1.  C2500是指平台类型

2.  J指示此文件时一个企业级映像文件

3.  S指示文件包含扩展性能

4.  L指示在需要时可以从闪存中删除此文件,并且此文件时不可压缩文件

5.  T12是版本号

6.  .bin指示Cisco IOS是二进制可执行文件

备份Cisco IOS

若要将Cisco IOS备份到TFTP服务器,使用copy flash tftp命令

恢复或升级Cisco路由器IOS

可以使用copy tftp flash命令将文件从TFTP服务器下载到闪存中。此命令需要TFTP服务器的IP地址以及要下载到闪存中的文件名。

在开始操作之前,要确保欲放置到闪存中的文件在服务器默认的TFTP目录下。

备份和恢复Cisco配置

对于路由器配置进行的任何修改存储在running-config文件中。在修改了running-config后没有执行copy run start命令,那么路由器重载或掉电后修改的内容会丢失。

备份Cisco路由器配置

要把路由器的配置文件从路由器复制到TFTP服务器,可以使用copy running-config tftp或copy startup-config tftp。其中一个备份当前正在DRAM中运行的路由器配置,一个备份存储在NVRAM中的路由器配置。

验证当前配置

可以使用sh running-config命令

Router>en

Router#sh run

Building configuration…

Current configuration : 547 bytes

!

version 12.1

当前信息表明路由器运行的是IOS 12.1版本

验证存储的配置

下面,应当检查NVRAM中存储的配置。要察看此配置,使用sh start命令:

Router#sh start

Using 547 out of 32762 bytes

!

version 12.1

将当前配置复制到NVRAM

将running-config复制到NVRAM作为备份,可以确信路由器重载时总是重载Running-config文件。

Router#copy run start

Destination filename [startup-config]? [Enter]

Building configuration…

[OK]

Router#

将配置复制到TFTP服务器

使用copy run tftp命令

恢复Cisco路由器配置

使用copy tftp run命令

删除配置

使用erase startup-config命令

Router#erase startup-config

Erasing the nvram filesystem will remove all files! Continue? [confirm][Enter]

[OK]

Erase of nvram: complete

Router#

使用Cisco发现协议

Cisco发现协议(CDP)是Cisco私有,帮助用来管理员收集本地相连和远程设备的信息.

获取CDP定时器和保持时间信息

之前提到过CDP的一些介绍,show cdp命令提供2个信息给你:

1.CDP timer:CDP包传给每个活跃接口的时间间隔,默认是60秒

2.CDP holdtime:某设备从相邻设备收到的包的保持时间,默认是180秒

如下:

Router#sh cdp

Global CDP information:

Sending CDP packets every 60 seconds

Sending a holdtime value of 180 seconds

Router#

可以修改默认的时间,分别在全局配置模式下使用cdp timer和cdp holdtime命令,如下:

Router#conf t

Router(config)#cdp timer 90

Router(config)#cdp holdtime 240

在所有接口上关闭CDP,在全局配置模式下使用no cdp run命令;关闭某个接口的CDP使用no cdp enable命令.再次打开分别使用cdp run和ccdp enable命令.如下:

Router(config)#no cdp run

Router(config)#int fa0/1

Router(config-if)#no cdp enable

收集邻居信息

使用show cdp neighbour可以显示直接相连的设备的信息,如下:

Router#sh cdp nei

Capability Codes: R – Router, T – Trans Bridge,

B – Source Route Bridge, S – Switch, H – Host,

I – IGMP, r – Repeater

Device ID Local Intrfce Holdtime Capability Platform Port ID

1900Switch Eth 0 238 T S 1900 2

2500B Ser 0 138 R 2500 Ser 0

Router#

一些选项的解释如下:

1.Device ID:直接相连的设备的主机名

2.Local Interface:接收CDP包的接口

3.Holdtime:某设备从相邻设备收到的包的保持时间,如果过了这个时间仍然没收到新的CDP包,就将被丢弃

4.Capability:见输出最顶部信息

5.Platform:Cisco设备的类型

6.Port ID:相连设备的接受CDP包信息的接口

要查看更为详细的CDP信息可以使用show cdp neighbor detail或show cdp entry *命令

收集借口流量信息

使用show cdp traffic命令显示接口CDP包流量信息,如下:

Router#sh cdp traffic

CDP counters:

Packets output: 13, Input: 8

Hdr syntax: 0, Chksum error: 0, Encaps failed: 0

No memory: 0, Invalid packet: 0, Fragmented: 0

Router#

收集端口和接口信息

使用show cdp interface命令显示接口的CDP状态信息

使用Telnet

在特权模式下使用telnet [IP地址]的命令进行telnet,如下:

Router#telnet 172.16.10.2

Trying 172.16.10.2 … Open

Password required, but none set

[Connection to 172.16.10.2 closed by foreign host]

Router#

由上面提示可以看出,VTY没有密码配置的话是不允许你telnet的(除非你使用了no login命令,但是安全性几乎为0).所以在telnet前,记得先给目标设备的VTY线路配置密码

同时Telnet到多个设备

当你telnet到远程设备的时候,可以在任何情况下使用exit命令来终止连接.但是假如你想保持这个连接,同时又对另外1个设备进行telnet的时候,使用Ctrl+Shift+6,再按下X键,就可以回到本地console,再对另外1设备进行telnet.如下:

2500#telnet 172.16.10.2

Trying 172.16.10.2 … Open

User Access Verification

Password:

2600>[Ctrl+Shift+6,X]

2500#telnet 192.168.0.32

(略)

检查Telnet连接

查看从本地到远程的连接会话,使用show sessions命令,如下:

2500#sh sessions

Conn Host Address Byte Idle Conn Name

1 172.16.10.2 172.16.10.2 0 0 172.16.10.2

*2 192.168.0.32 192.168.0.32 0 0 192.168.0.32

2500#

注意*所在的会话代表你的最后1个会话,可以直接敲2下Enter键回到*号会话,也可以输入前面的数字,再敲2下Enter键回到相应会话

检查Telnet用户

使用show users命令列举本地所有活动console和VTY端口,如下:

2500#sh users

Line User Host(s) Idle Location

* 0 con 0 172.16.10.2 00:07:52

192.168.0.32 00:07:18

注意上面输出的con代表本地console,这个例子可以看到从本地console连接了远程的2个设备.接下来在我们远程设备上使用这个命令,如下:

2600>sh users

Line User Host(s) Idle Location

0 con 0 idle 9

*2 vty 0

这个输出内容可以看出console是活动的,而且VTY端口2被使用

关闭Telnet会话

之前说过,要终止telnet会话,在远程(被telnet)设备上使用exit命令.但是要从本地设备终止会话的话,就需要在本地使用disconnect命令,如下:

2500#disconnect ?

<1-2> The number of an active network connection

WORD The name of an active network connection

<cr>

2500#disconnect 1

Closing connection to 172.16.10.2 [confirm]

2500#

验证如下:

2600#sh users

Line User Host(s) Idle Location

*0 con 0 idle 0

1 aux 0 idle 0

2 vty 0 idle 172.16.10.1

清除连接,使用clear line命令,并验证,如下:

2600#clear line 2

[confirm]

[OK]

2600#sh users

Line User Host(s) Idle Location

*0 con 0 idle 0

1 aux 0 idle 1

2600#

解析主机名

2种解析主机名到IP地址的办法:

1.在每个router上建立主机表(host table)

2.建立DNS服务器(Domain Name System server),这个类似动态主机表

建立主机表

主机表只提供包含其中的解析,建立主机表的命令是ip host [主机名] [TCP端口号] [IP地址],默认TCP端口号为23.1个主机可以对应最多8个IP地址.如下:

2500(config)#ip host 2501B 172.16.10.2

2500(config)#ip host 1900S 192.168.0.32

2500(config)#^Z

使用show hosts命令验证新建的主机表,如下:

2500#sh hosts

Default domain is not set

Name/address lookup uses domain service

Name servers are 255.255.255.255

Host Flags Age Type Address(es)

2501B (perm, OK) 0 IP 172.16.10.2

1900S (perm, OK) 0 IP 192.168.0.32

2500#

注意Flags选项的perm,代表是手动输入的,如果这项是temp的话,表明是由DNS解析的

使用DNS解析名称

假如你在CLI下输入了1个Cisco设备不能识别的命令,它会默认通过DNS来进行解析(它认为是主机名).这个不好的地方是要花费额外的时间等待DNS解析完.可以在全局配置模式下使用no ip domain-lookup命令关闭它

假如你在你的网络里有DNS服务器,可以使用1些命令使DNS解析开始工作:

1.第一条命令是:ip domain-lookup,这个命令默认是打开了的.如果你之前使用了no ip domain-lookup的话,就要用这条命令打开它

2.第二条命令是:ip name-server.设置DNS服务器的IP地址,可以使1个IP地址对应多达6个服务器

3.最后条命令是:ip domain-name.虽然这个命令是可选的,但是最好还是设置1下

实例如下:

2500(config)#ip domain-lookup

2500(config)#ip name-server 192.168.0.23

2500(config)#ip domain-name noko.com

2500(config)#^Z

2500#

可以使用ping命令来严正下,如下:

2500#ping 1900S

Translating “1900S”…domain server (192.168.0.23) [OK]

(略)

使用show hosts命令验证下,如下:

2500#sh hosts

Default domain is noko.com

Name/address lookup uses domain service

Name servers are 192.168.023

Host Flags Age Type Address(es)

2501B (perm, OK) 0 IP 172.16.10.2

1900S.noko.com (temp, OK) 0 IP 192.168.0.32

2500#

检查网络连接

使用ping命令和Traceroute命令

第十章,  使用访问列表管理流量

访问列表可以用于允许或拒绝包通过路由器、允许或拒绝Telnet(VTY)访问路由器、允许或拒绝来自路由器的Telnet访问,以及创建可以出发拨号到远程站点的流量。

访问列表简介

访问列表基本上是一系列对包进行分类的条件。

一个最常用和最容易理解的使用访问列表的情况是,实现安全策略时过滤不希望通过的包。

数据包和访问列表向比较时遵循的重要规则:

1.  通常是按顺序比较访问列表的每一行。

2.  比较访问列表的各行直到比较到匹配的一行。

3.  在每个访问列表的最后是一行隐含“deny”语句-意味着如果数据包与访问列表中的所有行都不匹配,将被丢弃。

访问列表有两种类型:

1.  标准的访问列表

2.  扩展的访问列表

3.  命名的访问列表(基于标准和扩展之间的)

在一个接口的输入方向和输出方向使用不同的访问列表:

1.  输入型访问列表 党访问列表被应用刀从接口输入的包时,那些包在被路由到输出接口之前要经过访问列表的处理。

2.  输出行访问列表 当访问列表被应用到从接口输出的包时,那些包首先被路由到输出接口,然后在进入该接口的输入队列之前经过访问列表的处理。

标准的访问列表

标准的IP访问列表通过使用IP包中的源IP地址过滤网络流量。可以使用访问列表号1-99或130-1999创建标准的访问列表。一般用号码区别访问列表类型。

通配符

通配符和访问列表一起用来指定一个主机、一个网络、一个网络或几个网络内的某个范围。

要理解通配符,需要理解什么是块大小,这里常常指地址范围。一些有效的块大小是64、32、16、8和4。

简单的描述,通配符相当于是子网掩码,不过刚好相反,0表示绝对匹配,1表示任意匹配。

标准的访问列表举例:

Lab_A#config t

Lab_A(config)#access-list 10 deny 172.16.40.0 0.0.0.255

Lab_A(config)#access-list 10 permit any

这个访问控制列表的意思是,拒绝所有172.16.40.0这个网段的数据

其他的数据都允许通过。

扩展的访问控制列表

扩展的访问列表允许指定源地址和目的地址,以及表示上层协议或应用的协议和端口号。通过使用扩展的IP访问列表,可以有效地允许用户访问物理

LAN的同时不允许访问特定的主机或甚至那些主机上的特定服务。

扩展的访问列表举例:

Lab_A#config

Lab_A(config)#access-list 110 deny tcp any host 172.16.30.5 eq 21

Lab_A(config)#access-list 110 deny tcp any host 172.16.30.5 eq 23

Lab_A(config)#access-list 110 permit ip any any

第一行和第二行意思是,拒绝所有目的地址是172.16.30.5的FTP访问和Telnet访问

第三行意思是,允许所有的数据通过。

第十一章,              广域网协议

定义WAN术语:

1.  Customer premises equipment,CPE(用户驻地设备)

2.  Demarcation point(分界点)

3.  Local loop(本地回路)

4.  Central office(中心局)

5.  Toll network(长途网络)

WAN连接类型

WAN可以使用许多不同的连接类型,这里只介绍市场上常见的各种WAN连接类型。

1.  专线

2.  电路交换

3.  分组交换

下面解释WAN连接类型:

1.  租用线路 租用线路典型地指点导电连接或专线连接。

2.  电路交换 电路交换的最大优势就是成本低。在端到端连接之前不能传输数据。电路交换使用拨号调制解调或ISDN,用于低带宽数据传输。

3.  包交换 允许和其他公司共向带宽以节省资金。如果需要经常传输数据,则不咬考虑这种类型,应当使用租用线路。

WAN支持

1.  帧中继

2.  ISDN

3.  LAPB

4.  HDLC

5.  PPP

6.  ATM

WAN布线

Cisco串行连接几乎支持WAN服务的任何类型。典型的WAN连接是使用HDLC、PPP、综合业务数字网和帧中继专线。

HDLC、PPP和帧中继可以使用同一种物理规范,但是ISDN在物理层有各种不相同的输出引脚和规范。

串行传输

WAN串行连接器使用串行传输,即一个信道一个时间只传输一位。

Cisco路由器使用专用的60针串行连接器,这种连接器只能从CiscoCisco设备服务提供商获得。

电缆另一端的连接器类型依赖于服务提供商或所需的终端设备。

各种可用的设备有:

1.  EIA/TIA-232

2.  EIA/TIA-499

3.  V.35

4.  X.21

5.  EIA-530

数据终端设备(DTE)和数据通信设备(DCE)

路由器接口默认情况下是数据终端设备(DTE),连接着数据通信设备(DCE)。

WAN的思想是能够通过DCE网络将两个DTE网络连接在一起。

固定接口和模块化接口

固定接口的路由器,如2500系列,具有不能更换的一套接口。1600、1700、2600、3600以及更高系列的路由器都具有模块化的接口,即允许你购买现在所需的接口并增加以后可能需要的任何类型的接口。

高级数据链路控制协议

HDLC是流行的ISO标准、面向位的数据链路层协议。它使用帧特性和效验和规定数据在同步串行数据链路上封装的方法。HDLC是一种用于租用线路的点到点协议。

在面向字节协议中,用整个字节对控制信息进行编码。

点到点协议

PPP是一种可以用于异步拨号或同步穿行介质的数据链路层协议。他使用LCP建立并维护数据链路连接。

PPP包含的主要组件:

EIA/TIA-232-C、V.24、V.35V和ISDN

HDLC

LCP

NCP

链路控制协议配置选项

链路控制协议提供各种PPP封装选项:

1.  Authentication(认证)

2.  Compression(压缩)

3.  Error detection (错误检测)

4.  Multilink(多链路)

5.  PPP回叫

PPP会话建立

当PPP连接开始时,连路经过三个会话建立阶段:

链路建立阶段每个PPP设备发送LCP包来配置和测试连路。

认证阶段如果配置了认证,在人证链路时可以使用CHAP或PAP。认证发生在读取网络层协议信息之前。

PPP认证方法

PPP链路可以使用两种认证方法:

口令认证协议(PAP) 口令认证协议是两种方法中安全程度较低的一种。口令以明文发送,并且PAP值在初始链路建立时执行。

问答握手认证协议(CHAP) 问答握手认证协议用于链路初始启动,和为了证实路由器连接的仍然是同一个主机而进行周期性链路检查。

Cisco路由器上配置PPP

Router#config t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#int s0

Router(config-if)#encapsulation ppp

Router(config-if)#^Z

Router#

配置PPP认证

将串行接口配置为支持PPP封装后,可以使用PPP在路由器之间配置认证。

Router#config t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname RouterA

RouterA(config)#username RouterB password 12345

当使用hostname命令时,要记住用户名师连接你路由器的远程路由器的主机名。

当设置了主机名、用户名和口令后,选择认证类型、CHAP和PAP:

RouterA#config t

Enter configuration commands, one per line.  End with CNTL/Z.

RouterA(config)#int s0

RouterA(config-if)#ppp authentication chap pap

RouterA(config-if)#^Z

RouterA#

验证PPP封装

使用show interface命令来验证配置。

帧中继

帧中继是从x.25技术发展来的。

帧中继技术简介

帧中继是包交换技术。

1.  不能使用encapsulation hdlc或encapsulation ppp命令进行配置。

2.  帧中继和点到点租用线路不一样。

3.  帧中继在许多情况下没有租用线路昂贵,但未了节省费用会有些损失。

帧中继技术

首先要知道这种技术的工作原理。

工作过程如下:

1.  用户网络主机在本地网络发送一个帧。

2.  路由器获得此帧,提取出数据包,丢弃剩下的帧。

3.  路由器然后从它认为可以找到远程网络的接口转发此数据。

4.  信道服务单元/数据服务单元(CSU/DSU)接收数字信号,并将信号编码为包交换机(PSE)可以理解的数字信号类型。

5.  CSU/DSU连接分界,分解由服务提供商安装并且位于服务提供商的第一个负责点。

6.  典型的分解时连接到本地回路的双绞线电缆。

7.  CO接收帧并通过帧中继“网云”发送到他的目的地。

8.  一旦帧到达最靠近目的交换局,就发送到本地回路上。

承诺信息率(CIR)

帧中继提供商同时为许多不能得客户提供包交换网络。

正中及通过每个用户提供部分专用带宽工作,并在电信网络有可用资源的情况下允许用户超过他们保证的带宽。

访问速率(Access rate) 帧中继接口可以传输的最大速率。

CIR 数据传输承诺的最大速率。

帧中继封装类型

当在Cisco路由器上配置帧中继时,需要在串行接口上将帧中继指定为一种封装。

RouterA(config)#int s0

RouterA(config-if)#encapsulation frame-relay ?

  ietf  Use RFC1490/RFC2427 encapsulation

  <cr>

除非手的输入ietf,否则默认的封装是Cisco,而且连接两个Cisco设备时使用Cisco类型。

虚电路

帧中继使用虚电路工作方式,对英语租用线路使用的真正电路。这些虚电路是连接到提供商“网云”上的几千个设备构成的链路。

本地管理接口

本地管理接口是路由器和它所连接的第一个帧中继交换机之间使用的信令标准。

它传输下列有关信息:

1.  保持激活

2.  组播

3.  全局寻址

4.  虚电路状态

帧中继拥塞控制

CIR设置的越低,数据被丢弃的危险就越大。

三种拥塞位和其意义:

1.  丢弃合格

2.  向前显示拥塞通知

3.  向后显示拥塞通知

帧中继的试验和监控

单个接口

RouterA#config

05:41:11: %SYS-5-CONFIG_I: Configured from console by consolet

Enter configuration commands, one per line.  End with CNTL/Z.

RouterA(config)#int s0

RouterA(config-if)#encapsulation frame-relay

RouterA(config-if)#ip addr 172.16.20.1 255.255.255.0

RouterA(config-if)#frame-relay lmi-type ansi

RouterA(config-if)#frame-relay interface-dlci 101

RouterA(config-fr-dlci)#^Z

子接口

可能在一个串行接口上有多条虚电路,并且将每个虚电路视为一个单独的接口,他被认为是子接口。

可以用int s0.subinterface number命令定义子接口。

点到点

当一个虚电路连接一个路由器到另一个路由时使用点到点子接口。

多点

档路由器位于星型虚电路的中心时使用多点子接口。

综合业务数字网

ISDN是一种在现有电话网上运行的数字服务。

PPP典型地用于ISDN,提供数据传输、链路集成和认证。

ISDN的优势有:

1.  可以同时承载语音、视频和数据。

2.  胡椒和建立比模拟调制解调器要快。

3.  数据传输率比模拟调制解调器连接要高。

4.  ISDN上的全时连接是由Cisco IOS路由器使用按需拨号路由技术造成的假象。

5.  使用ISDN BRI业务可以非常经济地支持小型办公室和家庭办公室站点。

6.  调制解调器的机架放置和布线问题可以通过在Cisco IOS网络接入服务器上集成数字调制解调器卡莱解决。

ISDN连接

ISDN是由两个64K的B信道和一个用于传输信令的16K的D信道组成。

ISDN BRI 路由器有一个U接口或一个S/T接口。

ISDN组件

ISDN使用的组件包括功能和参考点。

ISDN终端

连接到ISDN网络的设备是终端设备(TE)和网络终端(NT)设备。美中设备有两种类型:

1.  TE1

2.  TE2

3.  NT1

4.  NT2

5.  TA

ISDN参考点

参考电视一系列规范,定义用于ISDN网络中的各种设备之间的连接。ISDN有四种定义逻辑接口的参考点:

1.R R参考点定义非ISDN设备(TE2)和TA之间的连接点。

2.S S参考点定义客户路由器和NT2之间的连接点。

3.T T参考点定义NT1和NT2设备之间的连接点。

4.U U参考点定义NT1设备和载波网络中的线路终端设备之间的连接点。

基本速率接口

ISDN基本速率接口业务,也叫做2B+D,提供两个B信道和一个D信道,BRI的总带宽是144Kb/s

要设置BRI胡椒,必须经过四个步骤:

1.  路由器和本地ISDN交换机之间的D信道连接。

2.  ISDN交换机使用SS7信令技术建立到远程交换机的路径。

3.  然后B信道连接端对端。

基群速率接口

ISDN基群速率接口业务提供23个64Kb/s B信道和一个64Kb/s D信道,PRI的总带宽是2.048Mb/s

ISDN和Cisco路由器

对于每个ISDN BRI接口,需要使用isdn spid1和isdn spid2接口子命令指定SPID。

SPID配置的第二部分是那个SPID的本地拨号号码。

按需拨号路由选择

按需拨号路由选择用于允许两个或多个Cisco路由器在需要时使用ISDN拨号连接。

当接口接收到数据包符合管理员设定的访问列表的要求时DDR才工作。

5个步骤基本描述了党路由器接收到一个触发DDR的数据包时DDR是如何工作的:

1.  决定通过拨号连接到目的网络的路由。

2.  触发DDR的数据包指示一个DDR呼叫。

3.  查找拨号信息并进行拨号。

4.  传输流量。

5.  当链路上没有流量并且空闲超时时间到时胡椒结束。

配置DDR

配置DDR,需要执行三个任务:

1.  定义静态路由,定义如何到达远程网络以及通过什么接口到达。

2.  为路由器指定触发DDR的流量。

3.  配置拨号信息,拨号连接到达远程网络的接口时将使用此号码。

配置静态路由

创建静态路由时牢记下列问题:

1.  所有参与的路由器必须都有定义所有已知网络的静态路由。

2.  可以在存根网络中使用默认路由。

创建静态路由例子:

RouterA(config)#ip route 172.16.50.0 255.255.255.0 172.16.60.2

RouterA(config)#ip route 172.16.60.2 255.255.255.255 bri0

这样做是告诉路由器通过172.16.60.2可以到达网络172.16.50.0。第二行告诉路由器如何到达172.16.60.2。

指定触发DDR的流量

在每个路由器上设置了路由表以后,需要配置路由器决定什么流量启动ISDN线路。

RouterA(config)#dialer-list 1 protocol ip permit

RouterA(config)#int bri0

RouterA(config-if)#dialer-group 1

Dialer-group在BRI接口上设置访问列表。

配置拨号信息

配置拨号信息有五个步骤:

1.  选择接口。

2.  设置IP地址。

3.  配置封装类型。

4.  在接口上设置触发DDR的流量。

5.  配置一个或多个拨号号码。

五个步骤地例子:

RouterA#config

Enter configuration commands, one per line.  End with CNTL/Z.

RouterA(config)#int bri0

RouterA(config-if)#ip addr 172.16.60.1 255.255.255.0

RouterA(config-if)#no shut

RouterA(config-if)#encapsulation ppp

RouterA(config-if)#dialer-group 1

RouterA(config-if)#dialer string 8350661

不用dialer string命令,可以使用Dialer map命令,他提供更好的安全性。

RouterA(config-if)#dialer map ip 172.16.60.2 name RouterB 8350661

Dialer map命令可以和dialer-group命令及其相关的访问列表一起使用以初始化拨号。

必须知道的五个基本拨号影射步骤是:

1.  Dialer

2.  Map

3.  协议

4.  下一跳

5.  号码串

可选命令

Dialer load-threshold

Dialer idle-timeout

Dialer load-threshold命令告诉BRI接口什么时候启用第二个B信道。

Dialer idle-timeout命令指定在发送完最后一个触发DDR的流量之后到断开呼叫之前的秒数。

DDR和访问列表

RouterA(config)#dialer-list 1 protocol ip list 110

RouterA(config)#access-list 110 permit tcp any any eq smtp

RouterA(config)#access-list 110 permit tcp any any eq telnet

RouterA(config)#int bri0

RouterA(config-if)#dialer-group 1

这里不一定必须是IP协议,可以使用任何协议。

创建拨号列表,然后用dialer-group命令应用到BRI接口。

文章出自:CCIE那点事 http://www.jdccie.com/ 版权所有。本站文章除注明出处外,皆为作者原创文章,可自由引用,但请注明来源。 禁止全文转载。
本文链接:http://www.jdccie.com/?p=409转载请注明转自CCIE那点事
如果喜欢:点此订阅本站
上篇文章:
下篇文章:
  • 相关文章
  • 为您推荐
  • 各种观点

暂时还木有人评论,坐等沙发!
发表评论

您必须 [ 登录 ] 才能发表留言!