H3C NTP服务器相关配置

No Comments CISCO

配置NTP 服务器1. 组网需求
router1 设置本地时钟作为ntp 主时钟,层数为2,router2 以router1 作为时间服务器,将其设为server 模式,自己为client 模式。
2. 组网图

3. 配置步骤
(1) 配置router1
# 进入系统视图。
[h3c] system-view
# 设置本地时钟作为ntp 主时钟,层数为2。
[h3c] ntp-service refclock-master 2
(2) 配置router2
# 进入系统视图。
[h3c] system-view
# 设置router1 为时间服务器。
[h3c] ntp-service unicast-server 1.0.1.11
以上配置将router2 向router1 进行时间同步,同步前观察router2 的状态为:
[h3c] display ntp-service status
clock status: unsynchronized
clock stratum: 16
reference clock id: none
nominal frequency: 99.8562 hz
actual frequency: 99.8562 hz
clock precision: 2^7
clock offset: 0.0000 ms
root delay : 0.00 ms
root dispersion: 0.00 ms
peer dispersion: 0.00 ms
reference time: 00:00:00.000 utc jan 1 1900 (00000000.00000000)
同步后观测router2 的状态为:
[h3c] display ntp-service status
clock status: synchronized
clock stratum: 3
reference clock id: 1.0.1.11
nominal frequency: 250.0000 hz
actual frequency: 249.9992 hz
clock precision: 2^19
clock offset: 198.7425 ms
root delay : 27.47 ms
root dispersion: 208.39 ms
peer dispersion: 9.63 ms
reference time: 17:03:32.022 utc thu apr 6 2006 (bf422ae4.05aea86c)
此时router2 已经与router1 同步,层数比router1 大1,为3。
观察router2 的sessions 情况,router2 与router1 建立了连接。

H3C 对通过SNMP访问交换机的用户的ACL控制配置

No Comments CISCO

配置举例1. 组网需求

仅允许来自10.110.100.52和10.110.100.46的SNMP用户访问交换机。

2. 组网图

http://img.bimg.126.net/photo/sUOIc2b6-lAHgYRxJWKsCQ==/449234062847054837.gif

图3-3 对Switch的SNMP用户进行ACL控制

3. 配置步骤

# 定义基本访问控制列表和子规则。

<H3C> system-view

System View: return to User View with Ctrl+Z.

------中间广告---------

[H3C] acl number 2000 match-order config

[H3C-acl-baisc-2000] rule 1 permit source 10.110.100.52 0

[H3C-acl-baisc-2000] rule 2 permit source 10.110.100.46 0

[H3C-acl-basic-2000] rule 3 deny source any

[H3C-acl-baisc-2000] quit

# 引用访问控制列表。

[H3C] snmp-agent community read H3C acl 2000

[H3C] snmp-agent group v3 H3Cgroup acl 2000

[H3C] snmp-agent usm-user v3 H3Cuser H3Cgroup acl 2000

H3C配置对Telnet/SSH 用户的ACL 控制

9 Comments CISCO

配置对Telnet/SSH 用户的ACL 控制通过配置对telnet 或ssh 用户的acl 控制,可以在登录用户进行口令认证之前将一些恶意或者不合法的连接请求过滤掉,保证设备的安全。
4.2.1 配置准备
用户对telnet 或ssh 方式登录交换机进行了正确配置。
4.2.2 配置过程

缺省情况下,不对用户界面的呼入(inbound)/ 呼出(outbound)进行限制。
telnet 或ssh 用户的acl 控制功能只能引用基于数字标识的访问控制列表。
telnet 或ssh 用户引用基本访问控制列表或高级访问控制列表时,基于源ip或目的ip 地址对呼入/呼出进行限制。因此引用基本访问控制列表和高级访问控制列表子规则时,只有源ip 及其掩码、目的ip 及其掩码、time-range 参数有效。类似的,telnet 和ssh 用户引用二层访问控制列表时,基于源mac 地址对呼入/呼出进行限制。因此引用二层访问控制列表子规则时,只有源mac 及其掩码、time-range 参数有效。
基于二层访问控制列表对telnet、ssh 用户进行控制时,只能限制呼入。
对由于受acl 限制而被拒绝登录的用户,会记录一次访问失败日志信息。日志内容包括该用户的ip 地址、登录方式、登入用户界面索引值和登录失败原因。
4.2.3 二层acl 控制配置举例
1. 组网需求
仅允许源mac 地址为00e0-fc01-0101 和00e0-fc01-0303 的telnet 用户访问交换机。
2. 组网图

3. 配置步骤
# 定义二层访问控制列表。
[h3c] system-view
system view: return to user view with ctrl+z.
[h3c] acl number 4000 match-order config
# 定义子规则。
[h3c-acl-link-4000] rule 1 permit ingress 00e0-fc01-0101 0000-0000-0000 [h3c-acl-link-4000] rule 2 permit ingress 00e0-fc01-0303 0000-0000-0000 [h3c-acl-link-4000] rule 3 deny ingress any
[h3c-acl-link-4000] rule 3 deny ingress any
[h3c-acl-link-4000] quit
# 进入用户界面视图。
[h3c] user-interface vty 0 4
# 引用二层访问控制列表,对用户界面的呼入进行限制。
[h3c-user-interface-vty0-4] acl 4000 inbound
4.2.4 基本acl 控制配置举例
1. 组网需求
仅允许来自10.110.100.52 和10.110.100.46 的telnet 用户访问交换机。
2. 组网图

3. 配置步骤
# 定义基本访问控制列表。
[h3c] system-view
system view: return to user view with ctrl+z.
[h3c] acl number 2000 match-order config
# 定义子规则。
[h3c-acl-basic-2000] rule 1 permit source 10.110.100.52 0
[h3c-acl-basic-2000] rule 2 permit source 10.110.100.46 0
[h3c-acl-basic-2000] rule 3 deny source any
[h3c-acl-basic-2000] quit
# 进入用户界面视图。
[h3c] user-interface vty 0 4
# 引用访问控制列表。
[h3c-user-interface-vty0-4] acl 2000 inbound

H3C各种型号交换机端口镜像配置方法总结

No Comments CISCO

H3C各种型号交换机端口镜像配置方法总结一、端口镜像概念:
Port Mirror(端口镜像)是用于进行网络性能监测。可以这样理解:在端口A 和端口B 之间建立镜像关系,这样,通过端口A 传输的数据将同时复制到端口B ,以便于在端口B 上连接的分析仪或者分析软件进行性能分析或故障判断。
二、端口镜像配置
『环境配置参数』
1. PC1接在交换机E0/1端口,IP地址1.1.1.1/24
2. PC2接在交换机E0/2端口,IP地址2.2.2.2/24
3. E0/24为交换机上行端口
4. Server接在交换机E0/8端口,该端口作为镜像端口
『组网需求』
1. 通过交换机端口镜像的功能使用server对两台pc的业务报文进行监控。
2. 按照镜像的不同方式进行配置:
1) 基于端口的镜像
2) 基于流的镜像
2 数据配置步骤
『端口镜像的数据流程』
基于端口的镜像是把被镜像端口的进出数据报文完全拷贝一份到镜像端口,这样来进行流量观测或者故障定位。
【3026等交换机镜像】
S2008/S2016/S2026/S2403H/S3026等交换机支持的都是基于端口的镜像,有两种方法:
方法一
1. 配置镜像(观测)端口
[SwitchA]monitor-port e0/8
2. 配置被镜像端口
[SwitchA]port mirror Ethernet 0/1 to Ethernet 0/2
方法二
1. 可以一次性定义镜像和被镜像端口
[SwitchA]port mirror Ethernet 0/1 to Ethernet 0/2 observing-port Ethernet 0/8
【8016交换机端口镜像配置】
1. 假设8016交换机镜像端口为E1/0/15,被镜像端口为E1/0/0,设置端口1/0/15为端口镜像的观测端口。
[SwitchA] port monitor ethernet 1/0/15
2. 设置端口1/0/0为被镜像端口,对其输入输出数据都进行镜像。
[SwitchA] port mirroring ethernet 1/0/0 both ethernet 1/0/15
也可以通过两个不同的端口,对输入和输出的数据分别镜像
1. 设置E1/0/15和E2/0/0为镜像(观测)端口
[SwitchA] port monitor ethernet 1/0/15
2. 设置端口1/0/0为被镜像端口,分别使用E1/0/15和E2/0/0对输入和输出数据进行镜像。
[SwitchA] port mirroring gigabitethernet 1/0/0 ingress ethernet 1/0/15
[SwitchA] port mirroring gigabitethernet 1/0/0 egress ethernet 2/0/0
『基于流镜像的数据流程』
基于流镜像的交换机针对某些流进行镜像,每个连接都有两个方向的数据流,对于交换机来说这两个数据流是要分开镜像的。
【3500/3026E/3026F/3050】
〖基于三层流的镜像〗
1. 定义一条扩展访问控制列表
[SwitchA]acl num 100
2. 定义一条规则报文源地址为1.1.1.1/32去往所有目的地址
[SwitchA-acl-adv-101]rule 0 permit ip source 1.1.1.1 0 destination any
3. 定义一条规则报文源地址为所有源地址目的地址为1.1.1.1/32
[SwitchA-acl-adv-101]rule 1 permit ip source any destination 1.1.1.1 0
4. 将符合上述ACL规则的报文镜像到E0/8端口
[SwitchA]mirrored-to ip-group 100 interface e0/8
〖基于二层流的镜像〗
1. 定义一个ACL
[SwitchA]acl num 200
2. 定义一个规则从E0/1发送至其它所有端口的数据包
[SwitchA]rule 0 permit ingress interface Ethernet0/1 egress interface Ethernet0/2
3. 定义一个规则从其它所有端口到E0/1端口的数据包
[SwitchA]rule 1 permit ingress interface Ethernet0/2 egress interface Ethernet0/1
4. 将符合上述ACL的数据包镜像到E0/8
[SwitchA]mirrored-to link-group 200 interface e0/8
【5516/6506/6503/6506R】
目前该三款产品支持对入端口流量进行镜像
1. 定义镜像端口
[SwitchA]monitor-port Ethernet 3/0/2
2. 定义被镜像端口
[SwitchA]mirroring-port Ethernet 3/0/1 inbound
【补充说明】
1. 镜像一般都可以实现高速率端口镜像低速率端口,例如1000M端口可以镜像100M端口,反之则无法实现
2. 8016支持跨单板端口镜像端口镜像配置
『环境配置参数』
1. PC1接在交换机E0/1端口,IP地址1.1.1.1/24
2. PC2接在交换机E0/2端口,IP地址2.2.2.2/24
3. E0/24为交换机上行端口
4. Server接在交换机E0/8端口,该端口作为镜像端口
『组网需求』
1. 通过交换机端口镜像的功能使用server对两台pc的业务报文进行监控。
2. 按照镜像的不同方式进行配置:
1) 基于端口的镜像
2) 基于流的镜像
2 数据配置步骤
『端口镜像的数据流程』
基于端口的镜像是把被镜像端口的进出数据报文完全拷贝一份到镜像端口,这样来进行流量观测或者故障定位。
【3026等交换机镜像】
S2008/S2016/S2026/S2403H/S3026等交换机支持的都是基于端口的镜像,有两种方法:
方法一
1. 配置镜像(观测)端口
[SwitchA]monitor-port e0/8
2. 配置被镜像端口
[SwitchA]port mirror Ethernet 0/1 to Ethernet 0/2
方法二
1. 可以一次性定义镜像和被镜像端口
[SwitchA]port mirror Ethernet 0/1 to Ethernet 0/2 observing-port Ethernet 0/8
【8016交换机端口镜像配置】
1. 假设8016交换机镜像端口为E1/0/15,被镜像端口为E1/0/0,设置端口1/0/15为端口镜像的观测端口。
[SwitchA] port monitor ethernet 1/0/15
2. 设置端口1/0/0为被镜像端口,对其输入输出数据都进行镜像。
[SwitchA] port mirroring ethernet 1/0/0 both ethernet 1/0/15
也可以通过两个不同的端口,对输入和输出的数据分别镜像
1. 设置E1/0/15和E2/0/0为镜像(观测)端口
[SwitchA] port monitor ethernet 1/0/15
2. 设置端口1/0/0为被镜像端口,分别使用E1/0/15和E2/0/0对输入和输出数据进行镜像。
[SwitchA] port mirroring gigabitethernet 1/0/0 ingress ethernet 1/0/15
[SwitchA] port mirroring gigabitethernet 1/0/0 egress ethernet 2/0/0
『基于流镜像的数据流程』
基于流镜像的交换机针对某些流进行镜像,每个连接都有两个方向的数据流,对于交换机来说这两个数据流是要分开镜像的。
【3500/3026E/3026F/3050】
〖基于三层流的镜像〗
1. 定义一条扩展访问控制列表
[SwitchA]acl num 100
2. 定义一条规则报文源地址为1.1.1.1/32去往所有目的地址
[SwitchA-acl-adv-101]rule 0 permit ip source 1.1.1.1 0 destination any
3. 定义一条规则报文源地址为所有源地址目的地址为1.1.1.1/32
[SwitchA-acl-adv-101]rule 1 permit ip source any destination 1.1.1.1 0
4. 将符合上述ACL规则的报文镜像到E0/8端口
[SwitchA]mirrored-to ip-group 100 interface e0/8
〖基于二层流的镜像〗
1. 定义一个ACL
[SwitchA]acl num 200
2. 定义一个规则从E0/1发送至其它所有端口的数据包
[SwitchA]rule 0 permit ingress interface Ethernet0/1 egress interface Ethernet0/2
3. 定义一个规则从其它所有端口到E0/1端口的数据包
[SwitchA]rule 1 permit ingress interface Ethernet0/2 egress interface Ethernet0/1
4. 将符合上述ACL的数据包镜像到E0/8
[SwitchA]mirrored-to link-group 200 interface e0/8
【5516/6506/6503/6506R】
目前该三款产品支持对入端口流量进行镜像
1. 定义镜像端口
[SwitchA]monitor-port Ethernet 3/0/2
2. 定义被镜像端口
[SwitchA]mirroring-port Ethernet 3/0/1 inbound

H3C 镜像配置举例

No Comments CISCO

5.1 本地端口镜像配置举例1. 组网需求

用户网络描述如下:

l              部门 1的报文通过端口Ethernet1/1接入Device C。

l              部门 2的报文通过端口Ethernet1/2接入Device C。

l              Server接在Device C的Ethernet1/3端口上。

需求为:用户希望通过Server对部门 1和部门 2收发的报文进行监控。

使用本地端口镜像功能实现该需求,在Device C上进行如下配置:

l              端口Ethernet1/1和Ethernet1/2为镜像源端口。

l              连接Server的端口Ethernet1/3为镜像目的端口。

2. 组网图

http://img.bimg.126.net/photo/KSlsqzzk74jVvptgRRZ1tA==/449234062847054835.jpg

图1-4 配置本地端口镜像组网图

3. 配置步骤

在Device C上进行如下配置:

# 进入系统视图。

<DeviceC> system-view

# 创建本地镜像组。

[DeviceC] mirroring-group 1 local

# 为本地镜像组配置源端口和目的端口。

[DeviceC] mirroring-group 1 mirroring-port ethernet 1/1 ethernet 1/2 both

[DeviceC] mirroring-group 1 monitor-port ethernet 1/3

# 显示所有镜像组的配置信息。

[DeviceC] display mirroring-group all

mirroring-group 1:

type: local

status: active

mirroring port:

Ethernet1/1 both

Ethernet1/2 both

monitor port: Ethernet1/3

配置完成后,用户就可以在Server上监控部门 1和部门 2收发的所有报文。

1.5.2 远程端口镜像配置举例(配置方式一)1. 组网需求

用户网络描述如下:

l              部门 1的报文通过端口Ethernet1/1接入Device A。

l              部门 2的报文通过端口Ethernet1/2接入Device A。

l              Device A的Trunk端口Ethernet1/3和Device B的Trunk端口Ethernet1/1相连。

l              Device B的Trunk端口Ethernet1/2和Device C的Trunk端口Ethernet1/1相连。

l              Server接在Device C的Ethernet1/2端口上。

需求为:用户希望通过Server对部门 1和部门 2收发的报文进行远程监控。

使用远程端口镜像功能实现该需求,进行如下配置:

l              在Device A上配置远程源镜像组,定义VLAN 2为远程镜像VLAN,端口Ethernet1/1和Ethernet1/2为镜像源端口。

l              配置Device A的Ethernet1/3端口、Device B的Ethernet1/1和Ethernet1/2端口、Device C的Ethernet1/1端口为Trunk端口,并且端口均允许VLAN 2的报文通过。

l              在Device C上配置远程目的镜像组,定义VLAN 2为远程镜像VLAN,连接Server的端口Ethernet1/2为镜像目的端口。

2. 组网图

 

图1-5 配置远程端口镜像(配置方式一)组网图

3. 配置步骤

(1)        配置Device A(源设备)

# 进入系统视图。

<DeviceA> system-view

# 创建远程源镜像组。

[DeviceA] mirroring-group 1 remote-source

# 创建VLAN 2。

[DeviceA] vlan 2

[DeviceA-vlan2] quit

# 为远程源镜像组配置远程镜像VLAN和源端口。

[DeviceA] mirroring-group 1 remote-probe vlan 2

[DeviceA] mirroring-group 1 mirroring-port ethernet 1/1 ethernet 1/2 both

# 配置Ethernet1/3为Trunk端口,并且允许VLAN 2的报文通过。

[DeviceA] interface ethernet 1/3

[DeviceA-Ethernet1/3] port link-type trunk

[DeviceA-Ethernet1/3] port trunk permit vlan 2

(2)        配置Device B(中间设备)

# 进入系统视图。

<DeviceB> system-view

# 配置Ethernet1/1为Trunk端口,并且允许VLAN 2的报文通过。

[DeviceB] interface ethernet 1/1

[DeviceB-Ethernet1/1] port link-type trunk

[DeviceB-Ethernet1/1] port trunk permit vlan 2

# 配置Ethernet1/2为Trunk端口,并且允许VLAN 2的报文通过。

[DeviceB-Ethernet1/1] interface ethernet 1/2

[DeviceB-Ethernet1/2] port link-type trunk

[DeviceB-Ethernet1/2] port trunk permit vlan 2

(3)        配置Device C(目的设备)

# 进入系统视图。

<DeviceC> system-view

# 配置Ethernet1/1为Trunk端口,并且允许VLAN 2的报文通过。

[DeviceC] interface ethernet 1/1

[DeviceC-Ethernet1/1] port link-type trunk

[DeviceC-Ethernet1/1] port trunk permit vlan 2

[DeviceC-Ethernet1/1] quit

# 创建远程目的镜像组。

[DeviceC] mirroring-group 1 remote-destination

# 创建VLAN 2。

[DeviceC] vlan 2

[DeviceC-vlan2] quit

# 为远程目的镜像组配置远程镜像VLAN和目的端口。

[DeviceC] mirroring-group 1 remote-probe vlan 2

[DeviceC] interface ethernet 1/2

[DeviceC-Ethernet1/2] mirroring-group 1 monitor-port

[DeviceC-Ethernet1/2] port access vlan 2

配置完成后,用户就可以在Server上监控部门 1和部门 2收发的所有报文。

关于OSPF的COST 扩展研究(参考实验手册3.4)

No Comments CISCO

关于OSPF的COST 扩展研究(参考实验手册3.4):
本实验拓扑图如下:

实验目的:

正确配置,完成OSPF基本选路:
R3到达12.1.1.0/24 这一网络 ,S1/0和S2/0实现负载均衡
更改R2的S2/0 端口的COST值:110;
R1的S1/0端口的COST值:100;
影响R3到达12.1.1.0/24 的选路,说明OSPF更改COST可以影响到别人
当R1的S2/0端口DOWN掉,R3自动切换到R2到达12.1.1.0/24,查看OSPF数据库,
R2给R3的LSA-1里,包含了R2的各端口的 地址/对端接口/地址/链路开销……
扩展: 在R1上加一台路由器R4, R3到达4.4.4.0/24网络必须经过R2,R1,R4.
那这里R3要到达4.4.4.0/24的网络,是用R2的S2/0端口开销记算呢? 还是R1的S1/0 ?
反之,R4要到3.3.3.0/24 网络,又用哪个COST计算的呢?
总结OSPF 计算COST的值的步骤, 理解OSPF选路
目的一, R3实现负载均衡:
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
O    1.1.1.1 [110/65] via 13.1.1.1, 00:00:36, Serial1/0
2.0.0.0/32 is subnetted, 1 subnets
O    2.2.2.2 [110/65] via 23.1.1.2, 00:00:36, Serial2/0
3.0.0.0/24 is subnetted, 1 subnets
C    3.3.3.0 is directly connected, Loopback0
23.0.0.0/24 is subnetted, 1 subnets
C    23.1.1.0 is directly connected, Serial2/0
12.0.0.0/24 is subnetted, 1 subnets
O        12.1.1.0 [110/128] via 23.1.1.2, 00:00:36, Serial2/0
[110/128] via 13.1.1.1, 00:00:36, Serial1/0
13.0.0.0/24 is subnetted, 1 subnets
C    13.1.1.0 is directly connected, Serial1/0
配置完成,正确选路.开销为64+64=128
目的二, 分别更改R1和R2 在12.1.1.0/24 网络的COST值, 影响R3选路:
R2(config)#int s2/0
R2(config-if)#ip ospf cost 110
R1(config)#int s1/0
R1(config-if)#ip ospf cost 100
毫无疑问,这里R3到达12.1.1.0/24 网络要通过COST小的,也就是R1.
R3#     12.0.0.0/24 is subnetted, 1 subnets
O    12.1.1.0 [110/164] via 13.1.1.1, 00:24:14, Serial1/0
这证明:
OSPP里所有路由器的动作,是计算自己所有OSPF接口/链路的COST值,并通过
LSA-1通告出去! 同时把受到的到达各个网络的COST值 (包括自己链路) 相加,
选择最优的装进路由表.
目的三, 我们先来看一下OSPF的数据库, 了解LSA-1里面的一些内容:
R3#show ip ospf database router
OSPF Router with ID (3.3.3.3) (Process ID 10)
Router Link States (Area 0)
LS age: 556
Options: (No TOS-capability, DC)
LS Type: Router Links
Link State ID: 1.1.1.1
Advertising Router: 1.1.1.1
LS Seq Number: 80000007
Checksum: 0x5BEE
Length: 84
Number of Links: 5
Link connected to: a Stub Network
(Link ID) Network/subnet number: 12.1.1.0
(Link Data) Network Mask: 255.255.255.0
Number of TOS metrics: 0
TOS 0 Metrics: 100
LS age: 1168
Options: (No TOS-capability, DC)
LS Type: Router Links
Link State ID: 2.2.2.2
Advertising Router: 2.2.2.2
LS Seq Number: 80000005
Checksum: 0xCB4E
Length: 84
Number of Links: 5
Link connected to: a Stub Network
(Link ID) Network/subnet number: 12.1.1.0
(Link Data) Network Mask: 255.255.255.0
Number of TOS metrics: 0
TOS 0 Metrics: 110
R3 只是提取到同一网络最小 Metrics值,再和自己计算的链路COST, 做累加
100+64=164,装进路由表!
目的四, R1上加一台路由R4, 相当于:R4=>R1=>R2=>R3 串连, 拓扑如下:

http://img.bimg.126.net/photo/VafqzIEM3J2Iw0dvG4Eigg==/449234062847054834.jpg
R4正确配置, DOWN掉R1的S2/0端口,现在我们来看一下, R4到达3.3.3.0/24网络,
采用的是R1的100? 还是R2的110 ? 反之, R3到4.4.4.0/24 呢 ?
R4通过E0/0 连接R1, 并宣告进OSPF区域0:
R4#
router ospf 10
router-id 4.4.4.4
network 4.4.4.0 0.0.0.255 area 0
network 14.1.1.0 0.0.0.255 area 0
R4#show ip route
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
O    1.1.1.1 [110/11] via 14.1.1.1, 00:05:49, Ethernet0/0
2.0.0.0/32 is subnetted, 1 subnets
O    2.2.2.2 [110/111] via 14.1.1.1, 00:05:49, Ethernet0/0
3.0.0.0/32 is subnetted, 1 subnets
O    3.3.3.3 [110/175] via 14.1.1.1, 00:05:49, Ethernet0/0
4.0.0.0/24 is subnetted, 1 subnets
C    4.4.4.0 is directly connected, Loopback0
23.0.0.0/24 is subnetted, 1 subnets
O    23.1.1.0 [110/174] via 14.1.1.1, 00:05:49, Ethernet0/0
12.0.0.0/24 is subnetted, 1 subnets
O    12.1.1.0 [110/110] via 14.1.1.1, 00:05:49, Ethernet0/0
14.0.0.0/24 is subnetted, 1 subnets
C    14.1.1.0 is directly connected, Ethernet0/0
R3#show ip route
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
O    1.1.1.1 [110/175] via 23.1.1.2, 00:07:02, Serial2/0
2.0.0.0/32 is subnetted, 1 subnets
O    2.2.2.2 [110/65] via 23.1.1.2, 00:07:02, Serial2/0
3.0.0.0/24 is subnetted, 1 subnets
C    3.3.3.0 is directly connected, Loopback0
4.0.0.0/32 is subnetted, 1 subnets
O    4.4.4.4 [110/185] via 23.1.1.2, 00:07:02, Serial2/0
23.0.0.0/24 is subnetted, 1 subnets
C    23.1.1.0 is directly connected, Serial2/0
12.0.0.0/24 is subnetted, 1 subnets
O    12.1.1.0 [110/174] via 23.1.1.2, 00:07:02, Serial2/0
14.0.0.0/24 is subnetted, 1 subnets
O    14.1.1.0 [110/184] via 23.1.1.2, 00:07:03, Serial2/0
结论:
R4=>R1=>R2=>R3
COST=10+100+64+1
R3=>R2=>R1=>R4
COST=64+110+10+1
五,实验总结:
任何OSPF路由器,都是以自己为根, 通过链路状态, 计算出一棵树!
实验证明了COST值的累加,这里又有点距离矢量加跳数的意思. 错!
这个累加和(175)只是R4自己的动作! 所累加的每个COST值是每台路由器通告的最原始的!
对于R4而言, 自己为根, 最近的枝就是R1,通过R1的S1/0端口到达12.1.1.0/24,
以及后面的网络, 就算R2的LSA里的Metrics再小也不会采用!
R3则相反,反之亦然!
总结一句, 更改COST值时, 以目的网络为参考点, 所做的COST/参数改动,只对
其上游路由器 (包括本路由) 选路起作用!!!

路由器网络接口解析大全

No Comments CISCO

编者按:我们在这篇文章将通过一个例子对路由器网络接口进行全面的介绍和分析。我们分成三个部分进行阐述《路由器网络接口解析大全(一)》《路由器网络接口解析大全(二)》《路由器网络接口解析大全(三)》.下面我们详述第一部分内容:
目录
(1) 接口和活动状态
(2) 硬件字段为你提供接口的硬件类型
(3) Internet地址
(4) MTU
(5) BW
(6) DLY
(7) 可靠性
(8) 负载

Router# show interface e0/0 Ethernet0/0 is up, line protocol is down Hardware is AmdP2, address is 0009.4375.5e20 (bia 0009.4375.5e20) Internet address is 192.168.1.53/24 MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec, reliability 172/255, txload 3/255, rxload 39/255 Encapsulation ARPA, loopback not set Keepalive set (10 sec) ARP type: ARPA, ARP Timeout 04:00:00 Last input never, output 00:00:07, output hang never Last clearing of “show interface” counters never Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 Queueing strategy: fifo Output queue :0/40 (size/max) 5 minute input rate 0 bits/sec, 0 packets/sec 5 minute output rate 0 bits/sec, 0 packets/sec 0 packets input, 0 bytes, 0 no buffer Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored 0 input packets with dribble condition detected 50 packets output, 3270 bytes, 0 underruns 50 output errors, 0 collisions, 2 interface resets 0 babbles, 0 late collision, 0 deferred 50 lost carrier, 0 no carrier 0 output buffer failures, 0 output buffers swapped out
(1) 接口和活动状态
在上面的显示中,内容表示硬件接口是活动的,而处理行协议的软件过程相信此接口可用。如果路由器操作员拆卸此硬件接口,第一个字段将显示信息is administratively down.如果路由器在活动间隔内收到5000个以上的错误,单词Disabled将出现在此字段中,以显示连路由器自动禁用此端口。行协议字段还显示以前提到的三个描述之一:up、down、administratively down.如果字段项是up,则表示处理行协议和软件过程相信此接口可用,因为她正在接收keepalives的目的也是如此,其他设备可以确定某个空闲连接是否仍然活动。对于以太网接口,Keepalives的默认值是10s。我们不久将注意到,Keepalives设置可以通过为特定接口使用show interfaces命令来获得。可以用keepalive interface 命令来改变keepalives设置。此命令的格式如下:Keepalive seconds
(2) 硬件字段为你提供接口的硬件类型
在以上的例子中,硬件是CISCO扩展总线(CxBus)以太网,即接口处理器的533-Mbps数据总线。因此,硬件通知我们高速CxBus接口处理器用于支持以太网连接。同时还要注意显示字段包括接口的Mac地址。Mac是48位长的。因为Mac地址的头24位是表示生产厂家ID,所以十六进制数00-10-79是由IEEE分配给Csico的标识符。
(3) Internet地址
如果某个接口是为IP路由配置,那么将为它分配一个Internet地址。此地址后面是他的子网掩码。IP地址是205.141.192.1/24。反斜杠(/)后面表示此地址的头24位表示网络,他等于子网掩码255.255.255.0。
(4) MTU
最大传输单元(MTU)表示运行在接口上的协议的信息字段所支持的最大字节数。因为以太网桢的信息字段的最大长度是1500字节,所以它的MTU显示为1500字节。对于几乎所有的以太网应用程序,默认的1500字节MTU应该是有效的。对于令牌环,默认的MTU值为8192字节;但是应该注意的一点是RFC1191建议的MTU值为16-Mbps令牌环选择17914的,而为4-Mbps令牌环选择4464字节。最小的MTU是64个字节,而最大的值是65535字节。如果IP数据报超过最大的MTU,将对它进行分段,这将增加额外开销,因为每个最后的数据报都包含它自己的报头。虽然在高速LAN连接中,通常无需担心与分段有关的额外开销,但在低速串行接口上,这可能会是一个比较严重的问题。可以用MTUinterface命令来改变默认的MTU,此命令格式如下:
mtu bytes
字节数可以是从64~6553。
(5) BW
接口带宽(BW)通常指的是接口的运行速率,用每秒千字节表示。因为以太网运行速率为10Mbps,所以BW值显示为10 000Kb。
可以用Bandwidth命令设置信息带宽值,但实际上不用它来调整接口的带宽,因为对于某些类型的介质,如以太网,带宽是固定的。对于其他的介质,如串行线,通常通过调整硬件来调整其运行速率。例如通过DSU/CSU上设置不同的时钟速率来提高或降低串行接口的运行速率。因此,bandwidth命令主要目的是使当前带宽与高层协议通信。可以通过以下命令格式设置带宽值,千位表示以千位每秒表示的带宽。Bandwidth kilobits
(6) DLY
此字段表示接口的延迟,用微秒表示。以太网的延迟(DLY)为1000s。可以使用delay interface命令为接口设置延迟值。此命令的格式如下:
delay tens-of-microseconds
(7) 可靠性
可靠性字段表示接口的可靠性,用255分之几表示。此字段中所显示的值由在5分钟内的幂平均值计算。因为以太网为每个桢计算CRC,所以可靠性是基于CRC错误率,而不是位错误率。255/255表示接口在5分钟内100%可靠。
虽然没有可靠性命令,可以考虑定期使用的一个重要命令是clear conuter EXEC命令。此命令的功能是清楚或重置接口计数器。此命令的一般格式取决于正在使用的路由器。下面显示的是第二种格式用于Cisco7000系列产品:
clear counter [type number]
clear counter [type slot/port]
type表示特定的接口类型。如果你不指定特定接口,所有接口的计数器都被清除。
(8) 负载
接口上的发送和接收负载均显示为255分之几。与可靠性字段类似,负载字段也是计算5分钟内的幂平均值。从上面可以看出,发送(Txload)负载表示为3/255,而接收(rxload)负载为39/255。因为以太网运行速率为10Mbps,所以可以通过将每分数乘以运行速率来获得接口活动的一般指示。这是因为每个以太网桢都至少有26个额外字节,而当信息字段少于45字节时,将使PAD字符添加到信息字段中。【未完待续】

目录

(9)封装
(10)回送
(11)ARP类型
(12)ARP超时
(13)最后的输入和输出
(14)输出中断
(15)最后一次清除
(16)排队策略

(9)封装

此字段表示分配给接口的封装方法。在上面的例子中,封装显示为ARPA,他的标准的以太网2.0版封装方法。其他封装方法还包括IEEE 802.3以太网的关键字iso1,以及IEEE 802.3桢的关键字snap(子网访问协议)桢变异。

(10)回送

回送字段表示接口是否处于运行的回送模式。如果设置回送,这是当技术人员夜间将接口放入回送接口进行测试,而忘了重置回送时发生的常见问题,这会导致第二天早上会有一些有趣的电话打到控制中心。

可以使用Loopback interface设置命令将接口置于运行的回送模式。Loopback命令没有参数,应使用no Loopback命令删除或禁用回送。以下例子显示了将以太网接口设置为回送模式。

Interface ethernet0/0

Loopback

可以使用show interface loopback

EXEC命令查看回送的状态。如果你的路由器有大量的接口,并且技术人员进行定期检测,那么在一大早使用此命令以避免不必要的问题是一个不错的主意。

(11)ARP类型

此字段表示分配的地址解析协议(ARP)类型。在IP环境中,ARP类型是ARPA。默认情况下,以太网接口使用ARPA关键字以指定IP接口上的ARPA封装。可以通过使用arp interface 命令将封装更改为HP PROBE或SNAP,此命令格式如下:

arp {arpa/probe/snap}

请注意HP

Probe被IOS用于试图解析IEEE802.3或以太网本地数据连路地址。应将ARP类型设为probe,以使得一个或多个路由器接口透明地与使用称为”虚拟地址请求和回复”的地址解析技术的HP IEEE802.3 主机通信。

(12)ARP超时

此字段表示当非活动时,ARP项在清洗之前保留于缓存中的时间长度。ARP超时的默认值为4个小时,如上面例子所示:

可以通过使用ARP timeout命令调整 ARP缓存项在缓存中的时间长度。此命令格式如:

arp timeout seconds

(13)最后的输入和输出

此字段表示最后一个分组或侦被接口成功接收或发送以来的小时、分钟和秒数。可以使用此字段中的值确定活动接口是否依然激活或者死接口何时出现故障。关于前者,在第一个show interface 命令指示接口新的最后输出(这还可以指示是否有问题发生)后10秒或1分钟,再输入第二个show interface命令。它还表示如果出现问题,并非由于无法接收分组。例如,上面的例子中,最后一个成功输入发生在2秒之前。如果我们等待几秒,并发布又一个show interface命令,就可以获得对此计数器的更新。

(14)输出中断

输出中断字段表示自接口由于发送时间太长而进行最后一次重置以来的时间。此字段的值用小时、分钟和秒数指定,或者如果未发生中断(hang)情况,将永不显示。如果自最后一次重置以来的小时数超过24,将显示天数和小时数,直到字段益出。当发生此情形时,将在此字段中显示星号(*)。

(15)最后一次清除

此字段表示测量累计统计信息的接口计数器最后一次被重置为0的时间。清除会影响几乎所以的统计信息,除了诸如负载和可靠性等路由统计信息之外。

最后一次清除所显示的实际值是基于32位ms计数器的使用。显示星号表示经过的时间太长无法显示,而显示0:00:00表示计数器在2的31次幂ms到2的32次幂ms之前清除。在许多路由器上最后一次清除值将以星期和月或日和小时表示。例如,在上面的例子里,show interfaces计数器最后一次清除显示为1w2d。

(16)排队策略

此字段表示分配给接口的配对策略。默认为先入后出(First in first out ,FIFO)。如果以前为接口分配了优先级配对方式,将在此字段中列出此配对方法。【未完待续】

目录

(17)队列消息
(18)5-分钟I/O速率
(19)分组和字节输入
(20)无缓冲
(21)接收的广播
(22)Runts
(23)Giants
(24)Throttles

(17)队列消息

对于输出和输入队列,显示为m/n形式的一队数字,随后是由于队列已满而丢失的分组数。这里替代了m的值表示队列中的分组数,而替代n的值表示用分组表示最大队列大小。通过检查丢失的分组数以及在一段时间内m和n之间的关系,就可以确定是否需要建议对特定接口的队列长度进行调整以减少丢失的分组。但是,还应考虑与接口相连的介质和使用级别,以确定对输出队列长度进行调试是否有益。使用率高的介质最有可能引起队列中分组的丢失:路由器在传输数据时,将遭遇困难,从而导致输出分组排队,而这反过来导致当输出队列已满,且有其他分组到达以便通过接口传输到介质时出现分组丢失。在输入方,丢失的分组和m和n的较大比值表示路由器正忙于进行其他工作,而无法适时地处理进入的分组。如果次情形持续的时间比较长,则通常表示需要一个更强大的路由器以满足工作需要。通常,此情形可通过许多路由器接口的进入方向上的大量丢失的分组而观察到。

在上面的show interfaces中队列信息字段值显示目前任一队列中均无分组。而且,虽然输出队列已满而造成63个分组丢失,但没有分组由于输入队列而丢失。后者是一种常见情形,因为大多数路由器(除非配置过度)不应该在处理进入的数据方面有问题。

(18)5-分钟I/O速率

下一个字段显示在前5分钟通过接口发送和接收的平均位数和平均分组数。当解释在此字段中显示的数据时,必须考虑几个因素。首先,必须考虑接口的运行模式和接口相连的网络的配置。例如,如果接口是LAN接口,则即可以运行在混乱模式,从而度曲LAN上的每一侦,也可以运行在非混乱模式,即仅读取广播榛和直接投递到接口的桢。

如果端口处于混乱模式,则读取所有的分组,并提供一种测试在网络中流动的数据的方法。如果接口不处于混乱状态,则仅对她发送和接收的流量有感觉,这可能只占网络中所有流量的一小部分。

考虑到网络配置,如果接口连接到只有一个站的LAN,如WEB服务器,那么所有的流量将流经路由器的接口。这意味着可以获得一种相对准确的测试网络活动方法,而无需考虑接口所处的模式。

需要考虑的另一个因素是5分钟I/O速率表示5分钟时间常数的幂平均值之一事实。因此,任意一个5分钟I/O速率都是这段时间内每秒流量的大概值。但是4个5分钟的时间跨度所产生的平均值将在20分钟的统一流量的即时速率的2%以内。

因为分组的长度可变,所以每秒位率通常比从传输介质角度检查接口上的活动更有用。在上面的例子中,输入速率1540000bps约表示接口运行速率的1/6。你可能会感到奇怪,为什么输入速率比接口输出速率大将近一个数量级,回答在于接口的连接。在这一特定的路由器使用环境中,以太网接口连接到一个只具有一个另外的站(即公司WEB服务器)的10BASE-TLAN。WEB页请求以统一资源定位器(URL)的形式流动,而对URL请求的响应是WEB页;这解释了为什么输入和输出方向上的流量级别不成正比。现在,我们了解了5分钟I/O速率,接下来让我们介绍可为某个接口显示的特定分组的输入和输出信息。

(19)分组和字节输入

此字段首先表示路由器接收的无错误分组的总数量。其次,它还表示路由器接收的无错误分组的总字节数。

如果用字节数除以分组数,就可以获得字节表示的平均分组长度。此信息可用于为在接口上流动的流量类型提供一般表示。例如,相对短的分组通常传输交互式的查询/响应流量,而相对长的分组通常传输包括WEB页的文件及包含在大多数这些页中的图形。

(20)无缓冲

无缓冲字段表示接口所接收的、由于路由器缺乏缓冲空间而不得不丢弃的分组数。不要将此缓冲空间与接口的内部缓冲弄混。当出现连续的“无缓冲”情形时,通常表示路由器需要更多的内存。但是,如果定期遇到no buffers值,则可能是由于LAN上的广播风暴或者串行端口上的噪音发作所致。可以通过检查下一字段确定出现无缓冲值的原因是否属于广播风暴所致。

(21)接收的广播

此字段表示接口所接收的广播或多播分组的总数量。要注意的重要一点是许多广播是自然通信过程的一部分。例如,用于将第三层IP地址解析为第2层Mac地址的ARP取决于发放一个广播,以查询与必须获得的第3层地址相关的第2层地址的LAN的每一站,如此才能正确形成侦来传递分组。同样,在Novell IPX环境中,服务器每30s广播服务声明协议(SAP)分组。这些定义了服务器所提供的服务。

如果你是严格的IP环境,那么更有可能从ARP请求获得一部分广播。如果你具有以来于时间的应用程序,那么确确实实可以通过为运行以来于时间的应用程序将固定项设置为路由器的ARP缓存,从而用一个动作解决两个问题。这样做不仅可以避免路由器必须执行ARP操作,还允许解析过程通过检查内存而发生,这比等待广播的响应快得多。因为数据流量在ARP广播期间中断,所以减少ARP广播能够提高接口的信息传输功能。因为ARP表在路由器内部维护。

(22)Runts

Runt是一个错误情形术语,与它相关的分组长度小于某个协议相关的最小长度。在以太网环境中,最小分组长度在适配卡上是64字节,而在LAN上是72字节。因此,如果某个接口接收到以太网分组小于72字节,那么它将是一个错误情形,分组将被丢弃。通常,冲突可以引起Runt的产生,而出现故障的适配卡也可以引起此情形的发生。

(23)Giants

Giants是又一个错误情形。它表示分组超过了协议最大分组长度。在以太网环境中,适配卡的最大分组长度是1518字节,而在网络中流动的分组最大长度为1526字节。因此长度(包括前导码和起始界符字段)超过1526字节的分组被视为Giant。这样的分组也会被丢弃,而Giant数表示由于此情形而丢弃的分组数。导致Giant分组的通常原因是滞后冲突或适配卡出现故障。

(24)Throttles

虽然这样情形很少发生,但是如果路由器察觉缓冲或处理器过载,将关掉它的接收器。这一情形称为Throttles,而实际并非通信问题。相反,它是一个路由器功能问题,要求你检查系统缓冲及处理器的状态。如果使用show interfaces命令时指示有大量的“无缓冲”和Throttle,那么通常表示应考虑给路由器添加内存。【完】

Display interface的显示信息详解

No Comments CISCO

Display interface的显示信息详解Display interface的显示信息
本次工作希望统一Ethernet接口的信息,建议如下:
[1] GigabitEthernet3/0/1 current state : DOWN
[2] IP Sending Frames’ Format is PKTFMT_ETHNT_2, Hardware address is 00e0-fc00-0010
[3] The Maximum Transmit Unit is 1500
[4] Media type is not sure, loopback not set
[5] Port hardware type is No Connector
[6] Unknown-speed mode, unknown-duplex mode
[7] Link speed type is autonegotiation, link duplex type is autonegotiation
[8] Flow-control is not supported
[9] The Maximum Frame Length is 1536
[10] Broadcast MAX-ratio: 100%
[11] Allow jumbo frame to pass
[12] PVID: 1
[13] Port link-type: access
[14]    Tagged VLAN ID : none
[15]    Untagged VLAN ID : 504
[16] Last 5 minutes input rate 229 bytes/sec, 2 packets/sec
Last 5 minutes output rate 25 bytes/sec, 0 packets/sec
[17] Input(total):   34764 packets, 14212713 bytes
1021 broadcasts, 0 multicasts, 0 pauses
[18] Input(normal):   34764 packets, 14212713 bytes
1021 broadcasts, 0 multicasts, 0 pauses
[19] Input(error): 0 input errors, 0 runts, 0 giants,   0 throttles, 0 CRC, 0 frame,   0 overruns,
0 aborts, 0 ignored, 0 parity errors
[20] Output(total):   1630514 packets, 525467915 bytes                                
774493 broadcasts, 822714 multicasts, 0 pauses
[21] Output(normal):   1630514 packets, 525467915 bytes                                
774493 broadcasts, 822714 multicasts, 0 pauses
[22] Output(error):   0 output errors,   0 underruns, 0 buffer failures, 0 aborts,
0 deferred, 0 collisions, 0 late collisions, 0 lost carrier, 0 no carrier
注意:统计项中不支持的项目填写:-
即:如果产品对deferred,collisions, late collisions, lost carrier, no carrie不支持
显示结果如下:
Output:   0 output errors,   0 underruns, 0 buffer failures, 0 aborts,
– deferred, – collisions, – late collisions, – lost carrier, – no carrier
[1] 接口状态 显示硬件链路的状态
[2] 接口的输出帧封装类型和MAC地址 显示接口的删除帧封装类型和MAC地址
[3] 接口的最大传输单元 显示接口的最大传输单元
[4] 端口的连接线类型和环回状态 显示接口的连接线类型和环回状态
[5] 端口的连接器硬件类型 显示接口的连接器硬件类型
[6] 端口的实际速度和双工状态 显示端口的实际速度和双工状态
[7] 端口是否是速度、双工的自协商配置 显示端口速度、双工的自协商配置
[8] 端口流控状态 显示端口的MDI类型(不是缺省值的情况显示)
[9] 端口可以正常转发的帧长度 显示端口可以正常转发的帧长度
[10] 端口的广播抑制比 显示端口的广播抑制比
[11] 端口是否允许jumbo帧通过 显示端口是否允许jumbo帧通过
[12] 端口的PVID 显示端口的PVID
[13] 端口的链路类型 显示端口的链路类型(access,trunk,hybrid)
[14] 端口所属的tag的VLAN的列表 显示端口所属的tag的VLAN的列表
[15] 端口所属的untag的VLAN的列表 显示端口所属的untag的VLAN的列表
[16] 接口最近五分钟输出和输入速率和报文数 实现最近五分钟输出和输入速率和报文数
[17] 接口的物理层输入总值统计 显示物理层输出的报文数/字节数/广播和多播/PAUSE帧
总的统计值只包括正常、异常包和PAUSE帧
[18] 接口的物理层输入中正常帧的统计 显示物理层输出的报文数/字节数/广播和多播/PAUSE帧
正常帧的统计值包括正常数据帧和正常PAUSE帧
[19] 接口的物理层输入错误统计 输入错误数,input errors等于各种重要错误信息的总和。不同的产品可以根据具体情况增加其它参数,或减少不能实现的参数。
(1) Runts: discarded packets that are smaller than the medium’s minimum packet size.
( Receive Byte Count < 64 and NOT CRC Error 
or   Receive Byte Count < 64 and Tag Packet and NOT CRC Error,
无论是否有vlan tag,数据段小于64字节,而且没有CRC校验错误的帧。)
(2) Giants: discarded packets that are larger than the medium’s maximum packet size.
( Receive Byte Count > 1518 and NOT CRC Error 
or   Receive Byte Count > 1522 and Tag Packet and NOT CRC Error,
没有vlan tag,数据段大于1518字节,小于最大帧长度,而且没有CRC校验错误的帧,和有vlan tag,数据段大于1522字节,小于最大帧长度,而且没有CRC校验错误的帧。)
(3) Throttles: discarded packets that are incomplete frames.
( 交换机察觉缓存或CPU过载,关闭接口接收器的情形称为 throttle,是cisco路由器上的一个概念,我们的交换机目前不具备这个功能,一般应该显示为不支持。)
(4) CRC: discarded packets with checksum error.
( Receive Packet CRC error,帧长度在正常范围(不带tag,长度在64到1518之间,或带tag,长度在64到1522之间),而且CRC校验错,如果支持此项,则不支持奇偶校验错误项。)
(5) Frame: discarded packets with frame pad/sequence/alignment error, out of frame etc.
(   不是整数字节,而是多1~7bit,因此不对齐,或乱序或空帧,而且CRC校验错误,但是不计入CRC错误。)
(6) Overrun: the receiver hardware is unable to hand received data to a hardware buffer because the input rate exceeds the receiver’s ability to handle the data.
(   由于接口输入速率超过接受方处理能力,导致丢包,由于我们的交换机一般是线速转发,这项一般应该为0,只有部分交换机对上传CPU或三层线速转发的帧有接口带宽限制,或是通过ACL实现的带宽限制,因此被丢弃的帧,计入此项。)
(7) Aborts: Input abnormal frames that are discarded. 
( 除其他错误之外,产品认为有必要统计的错误,例如前导码异常的帧,计入此项。)
(8) Ignored: packets that are discarded because the interface hardware does not have enough internal buffers.
( Packet ignored,由于接口内部buffer满,丢弃的帧,与由于主系统缓存空间缺乏,导致的丢弃帧不同。线速转发的帧,在多接口满带宽输入,单接口输出等情况下,由于输出接口的带宽不足,数据帧将内部缓存占满,导致从接口输入的帧在进入内部缓存之前被丢弃,以及进入内部缓存的帧超时无法输出,计入此项,上传到CPU的帧,由于CPU处理能力限制,toCPU的缓存满,导致被丢弃,也计入此项。)
(9) Parity: Frames with parity error.
( Receive Packet parity error,如果支持此项,则不支持 CRC 错误项。)
[20] 接口的物理层输出总值统计 显示物理层输入的报文数/字节数/广播和多播/PAUSE帧
总的统计值只包括正常帧、异常帧和PAUSE帧。
Pauses: Flow control pauses including Xon and Xoff.
[21] 接口的物理层输出正常帧统计 显示物理层输入的报文数/字节数/广播和多播/PAUSE帧
总的统计值只包括正常数据帧和正常PAUSE帧。
[22] 接口的物理层输出错误统计 输入丢弃数/输入错误数,output errors等于各种重要错误信息的总和。不同的产品可以根据具体情况增加其它参数,或减少不能实现的参数。
(1) Underruns: There are no data in the output queue.
( Transmit under run,与 Overrun相反,输出接口的缓存从输出队列中取以太网帧时,没有帧,是一种非常少见的硬件异常。有的交换机就没有单独的接口输出缓存,与接口输出队列是同一块缓存。)
(2) Buffer failures: Hardware does not have enough internal buffers. 
( 内部缓存满,如果输出队列满,输出的以太网帧将在内部缓存中暂时存储,由于内部缓存满,导致帧丢弃。由于交换机对线速转发的数据帧发生的这种异常,认为只是到达内部缓存而没有到达出接口,是个输入帧,因此计入 Input Ignored Error,只有从CPU发出的帧,由于内部缓存满,导致帧丢弃,计入此项。)
(3) Aborts: Output abnormal frames that are discarded.
( 在半双工模式下,由于冲突检测,延迟发送超过15次的帧,被丢弃,计入此项。除其他错误之外,产品认为有必要统计的错误,例如添加前导码异常的帧,也计入此项)
(4) Deferred: The packets could not be sent out for collision under half-duplex mode.
( 半双工模式下,由于检测到载波正在被声明,当时没有发出的包,延时一次,计数加一。)
(5) Collisions: Statistic of collision detection under half-duplex mode.
( 半双工模式下,在以太网帧数据部分的前64字节进入线路前,由于检测到冲突,当时没有发出的包。)
(6) Late collisions: Statistic of collision with GE port sending packets less than 512 bytes and 10/100M port less than 64 bytes.
( 半双工模式下,在以太网帧数据部分的前64字节进入线路后,由于检测到冲突,当时没有发出的包。)
(7) Lost carrier: Statistic of losing the carrier.
(   载波丢失,一般适用于串行WAN接口,发送过程中,每丢失一个载波,此计数加一,对于交换机,通常是由于线路中断造成。)
(8) No carrier: Statistic of no carrier.
(   无载波,一般适用于串行WAN接口,当试图发送帧时,如果没有载波出现 ,此计数加一,对于交换机,通常是由于线路中断造成。)

以太网供电(PoE)常见问题

No Comments CISCO

以太网供电(PoE)常见问题
Cisco Catalyst 智能交换产品系列问:什么是以太网供电?

答:以太网供电是指在相同以太网铜缆上提供48V直流电源的能力。实施以太网供电需要两种主要设备——电源设备(PSE),即以太网上的LAN交换机或源电源供电,以及上电设备(PD),即从以太网电缆接收和使用电源以运行的终端设备。

问:馈线电源和以太网供电有什么不同?

答:二者意义相同。思科最初推出的上电以太网端口,我们称之为馈线电源。为统一术语,思科将“以太网供电”这一术语用于所有部署——无论是标准或预标准。

问:思科原始的PoE产品和IEEE 802.3af标准有何不同?

答:差别主要在于为连接设备提供的电量,发现设备所用的方法,以及当上电设备移除后,如何移除线路电量的问题。

问:新公布的Cisco Catalyst智能交换以太网供电(PoE)产品有哪些?

答:支持802.3af的Cisco Catalyst智能交换平台包括:

  • Cisco Catalyst 6500系列
    • 48端口10/100/1000(典型和SFM型)
    • 全新96端口典型10/100模块,带可选802.3af子卡
    • 48端口10/100(RJ-45和RJ-21)
  • Cisco Catalyst 4500系列
    • 48端口10/100/1000(RJ-45)802.3af PoE模块
    • 48端口10/100(RJ-45和RJ-21)802.3af PoE模块
  • Cisco Catalyst 3750系列
    • 48端口和24端口10/100 PoE 802.3af可堆叠交换机
  • Cisco Catalyst 3560系列
    • 48端口和24端口10/100 PoE 802.3af固定配置交换机

问:PoE有什么优势?

答:除了从以太网电缆为连接设备提供通用供电支持外,PoE降低了投资开支,从而降低了在统一IP基础设施中整合入上电设备的总部署成本。PoE免除了为终端设备安装墙壁电源连接的需要,因而降低了与支持终端设备相关的电源插座成本。它还可在部署本地交流电源较为困难的场所安装网络连接设备,从而提供了更大的灵活性。

问:新推出的PoE线路卡、可堆叠和固定配置交换机是否也支持思科预标准上电终端设备?

答:支持。思科承诺将尽可能多地提供投资保护,因此,所有这些全新802.3af PoE产品都支持思科预标准PoE实施,当然,也向后兼容思科现有上电终端设备,如IP电话和无线LAN接入点。

问:什么是思科智能电源管理?

答:思科智能电源管理是Cisco Catalyst交换机所提供的一组功能,实现了供电逐步优化和控制。智能电源管理允许用户更好地管理电量过使用,包括设置预定义每端口电量分配,发现未用电端口,重新配电,以及为防止交换机电量耗尽而提供的供电优先级划分。智能电源管理还允许LAN交换机在为每台兼容连接设备识别和预留电量方面拥有更精确的控制能力。智能电源管理构建于IEEE电量分类特性的基础上,可确定兼容终端设备的实际用电需求,而非仅仅采用电量级别。因此,可为LAN交换机更精确地预留电量,允许连接更多设备,极大地降低了必要用电量以外的电力需求。

问:是否所有上电终端设备都支持精确的电量控制特性?

答:不是。只有支持思科发现协议的兼容设备,如思科IP电话或无线接入点,拥有支持这一精确发现流程的能力。

问:什么是IEEE电量分类特性?

答:IEEE电量分类是IEEE 802.3af标准的可选内容。交换机或终端设备供应商无需实施该特性,但它的确是非常重要的,因为它可确定所连上电设备的电量需求。思科已在所有802.3af兼容产品上实施了该功能。该特性很实用,需在终端设备和LAN交换机上实施。

问:可选电量分类特性包括哪些内容?

答:针对电源设备(PSE)的相关输出电量,这一可选IEEE 802.3af特性定义了三种电量分类级别和一种缺省模式(检测不到或不支持分类),此外还为每一级别定义了上电设备的最大输入电量。

表3 IEEE 802.3af电量分类 IEEE类别 PSE最大输出电量 上电设备最大输入电量 0(缺省模式) 15.4W 0.44-12.95W 1 4.0W 0.44-3.84W 2 7.0W 3.84-6.49W 3 15.4W 6.49-12.95W
问:为什么PSE端口供电量和PD最大输入电量间存在差别?

答:这是由供电效率和电量损耗造成的。电量穿过电线或在电源中转换时,过程中都会出现电量损耗。在802.3af标准中,上电设备必须提供最高达15.4W的电量。但是,在电缆末端,该标准只要求提供12.9W。对LAN交换机来说,从供电到物理上电端口也是如此。可以查看各个产品的具体情况,来确定为在端口提供15.4W,电源需提供多少电量。

问:是否会出现额外热量?LAN交换机是否会因用电量高而生成更多的热量?

答:会的,但是额外生成的热量并不多。热量在用电处散发,因为终端上电设备在使用来自PoE的大量电量,因此热量在终端设备连接处而非LAN交换机内散发。如前所述,必须考虑到供电效率问题,而供电到交换机端口的电量损耗会带来更多的热量散发。具体信息请查看每个产品的规格。

问:能否说明我的客户为什么还需要继续购买思科预标准PoE线路卡?有没有计划何时中止销售?

答:应鼓励客户为所有全新部署购置新的IEEE 802.3af线路卡,以尽可能获取最大限度的投资保护。当前尚没有中止销售思科预标准线路卡的计划。

问:思科是否提供了一个PoE移植计划?

答:是的,为与思科标准IEEE 802.3af PoE兼容型交换产品的推出相配合,思科公布了一项特殊的奖励折扣积分计划,当升级至特定新型IEEE 802.3af标准PoE交换产品时,可提供高达65%的奖励积分。该计划采用了思科技术移植计划(TMP)中的特定折扣途径。请参见以太网供电站点的中移植计划信息。

问:如果我对新Cisco Catalyst交换产品有特殊的疑问,应该与谁联系?

答:欲获产品具体信息,请联络:

  • Catalyst 6500
  • Catalyst 4500
  • Catalyst 3750
  • Catalyst 3560

Cisco 2600系列、Cisco 3600系列和Cisco 3700系列路由器问:思科是否为思科路由器推出了兼容IEEE 802.3af的EtherSwitch端口?

答:否。Cisco 2600系列、Cisco 3600系列和Cisco 3700系列路由器提供了16和36端口10/100 EtherSwitch网络模块,以支持思科预标准PoE。

问:这些馈线电源网络模块是否支持全新思科IEEE 802.3af IP电话7970G(产品编号:CP-7970G)?

答:支持。

思科IP电话7970G问:思科IP电话7970G支持何种PoE标准?

答:思科IP电话7970G支持IEEE 802.3af和思科预标准PoE,这是公司对两种开放标准和投资保护承诺的有力证明。思科IP电话7970G新近在UNH互操作实验室完成了以太网供电协会Clause 33PD参数测试,没有出现任何问题。

问:思科IP电话7970G从思科交换机请求获得的电量级别是多少?

答:在思科发现协议中,思科IP电话7970G请求获得的是6.3W(低供电模式)和11W(全供电模式)。

问:建议使用的供电选项是什么?是本地电源还是馈线电源?

答:本地电源(供电室)。为使思科IP电话7970G获得全显示屏亮度,需要外部电源适配器,这是建议使用的供电选项。如通过思科预标准或IEEE 802.3af供电时,电话可正常运行,但显示屏亮度只有一半。

问:为什么思科IP电话7970G使用PoE时亮度只有一半?

答:思科IP电话7970G的全显示屏亮度需用电11W。目前,思科发现协议实施允许仅对电话提供6.3W的电量,即支持低供电模式。对于思科交换机的思科发现协议改进正在推出,拓宽了电量范围。改进计划不久就会公布。

问:是否有允许思科IP电话7970G使用PoE获得全屏亮度的计划?

答:有。为使思科IP电话7970G使用PoE获得全屏亮度,需要改进运行在支持IEEE 802.3af的思科交换机中的思科发现协议。该改进计划正在研究中,不久就会公布。

问:如果同时使用思科预标准PoE或IEEE 802.3af PoE和本地电源,思科IP电话7970G是否会处于无中断冗余电源模式?

答:它会运行于一种冗余电源模式,但不属于无中断冗余电源模式。如果同时使用思科预标准PoE或IEEE 802.3af PoE和本地电源,思科IP电话7970G会选择本地电源。当电话检测到主电源断电,会执行重启(丢弃现行呼叫),并在恢复正常运行前,从备用电源(如存在)获取电量。

如果目标是实现无中断运行,思科建议客户采用带备用电源和馈线供电模式的思科交换机。注:直至思科发现协议改进出现前,该配置都会将屏幕限制为半亮模式。

问:当与第三方IEEE兼容交换机共同运行时,是否需要注意什么?

答:如果第三方交换机未能运行思科发现协议,思科IP电话7970G可能无法给交换机提供所需的电量级别。在最好的情况下,这意味着思科IP电话7970G在采用馈线电源时,将无法支持全亮度模式。在最坏的情况下,思科IP电话7970G连接到第三方IEEE兼容交换机时,可能会出现运行行为不一致的现象。IEEE 802.3af是一种基于硬件的标准,并不会命令终端设备如何与交换机协调电量需求。在思科产品中,思科发现协议正是协调这一需求的机制。

问:思科计划何时在IP电话中提供千兆位以太网(GbE)支持?

答:思科计划在不久的将来推出支持10/100/1000的IP电话。具体日期未定。10/100/1000不属于对电话的GbE支持,而是指穿过GbE连接到与IP电话相连的PC的性能。部署带PoE的10/100/1000交换机端口的客户依然可以为任何连接的思科IP电话提供全面支持和供电,但可能无法实现GbE优势,因为电话将以100Mbps的速度建立到LAN交换机的连接,并只以100Mbps速度穿越至相连的PC。但是,当连接的是兼容设备时,端口可达到1000Mbps。当前,部署10/100/1000 PoE端口,会为客户提供投资保护,未来10/100/1000 PoE设备面世时,就无需再更换该端口。

问:新型思科IP电话是否支持预标准PoE?

答:支持。随着新型IP电话的推出,思科将尽可能多地为预标准和标准802.3af PoE二者提供支持。因此,客户将可以继续充分利用当前大量安装的现有PoE端口。但是,随着全新高级PoE上电设备的不断涌现,可能所需要的供电量将超出预标准端口的能力。所以,支持可能会随着设备而有所变化。

思科接入点和网桥

问:思科接入点和网桥是否兼容IEEE 802.3af?

答:不兼容。但是,Cisco Aironet 1100系列和1200系列接入点和350系列网桥可通过思科发现协议支持以太网供电,而思科预标准PoE和IEEE 802.3af交换机和路由器都支持该协议。1400系列网桥需要的电量比IEEE 802.3af端口所能提供的电量高,因而配备有自身的输电设备。

问:1100、1200系列接入点和350系列网桥是否可升级支持802.3af?

答:不可以。目前尚未有计划提供当前产品的硬件升级,以支持802.3af。

问:思科是否将提供IEEE 802.3af兼容接入点?

答:思科的计划是在未来的版本中提供接入点,支持思科预标准和IEEE 802.3af兼容PoE。a

问:Cisco Aironet输电设备是否支持802.3af?

答:不支持。输电设备支持思科电话发现协议,与Cisco Aironet接入点和网桥兼容。