标签:ospf

OSPF 配置指南

No Comments CISCO

OSPF
8.1.     配置OSPF
提问 NT-FAMILY: 宋体">在网络中启用OSPF
回答
Router5#configure terminal
Enter configuration commands, one per line.     End with CNTL/Z.
Router5(config)#router ospf 87
Router5(config-router)#network 0.0.0.0 255.255.255.255 area 0
Router5(config-router)#exit
Router5(config)#end
Router5#
注释 这里OSPF的进程号是本地使用,不需要像EIGRP一样整个网络保持一致。在12.3(11)T以后有一个专门的命令来指定端口加入OSPF 区域,而不需要用network的命令
Router9#configure terminal
Enter configuration commands, one per line.     End with CNTL/Z.
Router9(config)#router ospf 87
Router9(config-router)#exit
Router9(config)#interface FastEthernet0/0
Router9(config-if)#ip address 172.18.5.9 255.255.255.0
Router9(config-if)#ip ospf 87 area 10
Router9(config-if)#exit
Router9(config)#end
Router9#
8.2.     路由过滤
提问 进行路由过滤,只允许OSPF宣告特定路由进入路由表
回答
入方向
Router5#configure terminal
Enter configuration commands, one per line.     End with CNTL/Z.
Router5(config)#access-list 1 deny 172.20.10.0
Router5(config)#access-list 1 permit any
Router5(config)#router ospf 87
Router5(config-router)#distribute-list 1 in Ethernet0/0
Router5(config-router)#exit
Router5(config)#end
Router5#
注释 根据OSPF的机制,所有区域内的路由器LSA数据库内容必须保持一致,所以正常情况下不能对出方向进行过滤,入方向过滤也是防止其进入路由表,在本地的LSA数据库还是有此路由。当然如果确实需要对出方向进行过滤就必须对出方向所有的LSA进行过滤,这样会导致下游路由器的LSA数据库不完整,一般不推荐使用。
点对多点链路出方向过滤
Router1#configure terminal
Enter configuration commands, one per line.     End with CNTL/Z.
Router1(config)#router ospf 87
Router1(config-router)#neighbor 192.168.1.3 database-filter all out
Router1(config-router)#exit
Router1(config)#end
Router1#
广播,点到点链路出方向过滤
Router1#configure terminal
Enter configuration commands, one per line.     End with CNTL/Z.
Router1(config)#interface Serial0/0
Router1(config-if)#encapsulation frame-relay
Router1(config-if)#exit
Router1(config)#interface Serial0/0.10 multipoint
Router1(config-subif)#ip address 192.168.1.1 255.255.255.0
Router1(config-subif)#ip ospf network broadcast
Router1(config-subif)#ip ospf database-filter all out
Router1(config-subif)#frame-relay map ip 192.168.1.3 101 broadcast
Router1(config-subif)#frame-relay map ip 192.168.1.5 109 broadcast
Router1(config-subif)#exit
Router1(config)#router ospf 1
Router1(config-router)#network 0.0.0.0 255.255.255.255 area 10
Router1(config-router)#exit
Router1(config)#end
Router1#
8.3.     调整OSPF代价值
提问 调整OSPF链路的代价值
回答
全局调整
Router5#configure terminal
Enter configuration commands, one per line.     End with CNTL/Z.
Router5(config)#router ospf 87
Router5(config-router)#auto-cost reference-bandwidth 1000
Router5(config-router)#exit
Router5(config)#end
Router5#
接口调整
Router5#configure terminal
Enter configuration commands, one per line.     End with CNTL/Z.
Router5(config)#interface Ethernet0
Router5(config-if)#ip ospf cost 31
Router5(config-if)# exit
Router5(config)#end
Router5#
注释
8.4.     宣告缺省路由到OSPF
提问 宣告缺省路由到OSPF网络
回答
Router1#configure terminal
Enter configuration commands, one per line.     End with CNTL/Z.
Router1(config)#ip route 0.0.0.0 0.0.0.0 172.25.1.1
Router1(config)#router ospf 55
Router1(config-router)#default-information originate metric 30 metric-type 1
Router1(config-router)#exit
Router1(config)#end
Router1#
注释 在这里不能使用再发布静态路由得命令来发布缺省路由
8.5.     再发布静态路由到OSPF
提问 宣告一条或者多条静态路由到OSPF
回答
Router1#configure terminal
Enter configuration commands, one per line.     End with CNTL/Z.
Router1(config)#ip route 192.168.10.0 255.255.255.0 172.22.1.4
Router1(config)#ip route 172.24.1.0 255.255.255.0 172.22.1.4
Router1(config)#ip route 10.100.1.0 255.255.255.0 172.22.1.4
Router1(config)#router ospf 55
Router1(config-router)#redistribute static    
% Only classful networks will be redistributed
Router1(config-router)#exit
Router1(config)#end
Router1#
注释 根据上面得命令提示可以看到缺省情况下OSPF只再发布有类得路由,所以按照例子上虽然三条静态路由但是只有192.168.10.0/24是有类路由,能够发布出去,其它两个就不行。这时候就需要配置redistribute static subnets命令来发布子网,当然也可以添加metric等选项

8.6.     再发布外部路由到OSPF
提问 再发布其它路由协议得路由信息到OSPF
回答
Router1#configure terminal
Enter configuration commands, one per line.     End with CNTL/Z.
Router1(config)#router ospf 55
Router1(config-router)#redistribute eigrp 11 subnets  
Router1(config-router)#exit
Router1(config)#end
Router1#
在12.3(2)T以后增加了下面得命令对再发布过来得条目做了限制
Router1(config-router)#redistribute maximum-prefix 1000 80

注释 这里还是要注意subnet得参数。对于最后一个条目限制得命令,第一个1000是路由条目数,第二个80是百分比
8.7.     DR选举
提问 对DR选举做人为控制
回答
Router5#configure terminal
Enter configuration commands, one per line.     End with CNTL/Z.
Router5(config)#interface Ethernet0
Router5(config-if)#ip ospf priority 10                 
Router5(config-if)#exit
Router5(config)#end
Router5#
注释 DR选举人工控制最重要得两种情况是MOSPF和NBMA网络。在MOSPF网络中,MOSPF得DR和正常OSPF得DR是相同得,而如果DR不是一个MOSPF得路由器那么所有组播得路由就不能转发,思科路由器是不支持MOPSF得,所以在这种情况下必须使用ip ospf priority 0得命令来禁止其称为BDR或者DR。在NBMA得网络中要不DR设置在Hub路由器上。还有一个重要得问题是DR是不能强占得,如果网络中已经有了DR,这时即使新加入得路由器有更高得优先级他也不能称为DR,必须等待现在得DR出了问题才可以重新选举为DR。
8.8.     设置OSPF RID
提问 人工设定路由器得Router ID
回答
一种是Loopback地址方式
Router5#configure terminal
Enter configuration commands, one per line.     End with CNTL/Z.
Router5(config)#interface Loopback0
Router5(config-if)#ip address 172.25.25.6 255.255.255.255
Router5(config-if)#exit
Router5(config)#end
Router5#
一种是Router ID命令方式
Router5#configure terminal
Enter configuration commands, one per line.     End with CNTL/Z.
Router5(config)#router ospf 87
Router5(config-router)#router-id 172.25.1.7
Router5(config-if)#exit
Router5(config)#end
Router5#
注释 缺省会用最大IP地址作为Router ID。Router id命令后面得IP地址可以随意,不需要必须是存在得地址。另外router id一旦定下来以后,即使重新修改了地址也不能变更,必须通过clear
ip ospf process得方式或者reload得方式来改变
8.9.     启用OSPF鉴权
提问 对邻居关系建立启用鉴权从而保证网络设备得安全性
回答
Router1#configure terminal
Enter configuration commands, one per line.     End with CNTL/Z.
Router1(config)#interface Serial0/1
Router1(config-if)#ip ospf message-digest-key 1 md5 oreilly
Router1(config-if)#exit
Router1(config)#router ospf 55
Router1(config-router)#area 2 authentication message-digest
Router1(config-router)#exit
Router1(config)#end
Router1#
注释 注意得是不同厂商得OPSF MD5加密认证互联可能会有问题,因为RFC没有规范。对于新老密码替换得问题,通过配置新旧两个密码得方式来解决
8.10.     选择合适得区域类型
提问 不同得区域有不同得链路状态数据库,通过不同区域得选择来节省路由器资源和更快收敛
回答
Stubby Area
Router1#configure terminal
Enter configuration commands, one per line.     End with CNTL/Z.
Router1(config)#router ospf 55
Router1(config-router)#area 100 stub
Router1(config-router)#exit
Router1(config)#end
Router1#
Totally Stubby Area
Router1#configure terminal
Enter configuration commands, one per line.     End with CNTL/Z.
Router1(config)#router ospf 55
Router1(config-router)#area 100 stub no-summary
Router1(config-router)#exit
Router1(config)#end
Router1#
Not So Stubby Areas (NSSA), 同时生成一条缺省路由
Router1#configure terminal
Enter configuration commands, one per line.     End with CNTL/Z.
Router1(config)#router ospf 55
Router1(config-router)#area 100 nssa default-information-originate
Router1(config-router)#exit
Router1(config)#end
Router1#
Totally Stubby, Not So Stubby Area.
Router1#configure terminal
Enter configuration commands, one per line.     End with CNTL/Z.
Router1(config)#router ospf 55
Router1(config-router)#area 100 nssa no-summary
Router1(config-router)#exit
Router1(config)#end
Router1#

注释 这些都是在ABR上的配置,对于区域里面其它的路由器就是只有NSSA和stub的配置没有必要配置是否为totally stubby。
8.11.     在拨号接口上配置OSPF
提问 在拨号接口上启用OSPF,但又不想让OSPF的协议数据一直保持拨号链路处于激活状态
回答
下面例子是R4只能拨号到R1
Router4#configure terminal
Enter configuration commands, one per line.     End with CNTL/Z.
Router4(config)#username Router1 password 0 cisco
Router4(config)#interface BRI0
Router4(config-if)#ip address 192.168.15.4 255.255.255.0
Router4(config-if)#encapsulation ppp
Router4(config-if)#ip ospf demand-circuit
Router4(config-if)#dialer map ip 192.168.15.1 broadcast 4165550000
Router4(config-if)#dialer-group 1
Router4(config-if)#isdn switch-type basic-ni
Router4(config-if)#isdn spid1 416555001000 4165550010
Router4(config-if)#isdn spid2 416555001100 4165550011
Router4(config-if)#ppp authentication chap
Router4(config-if)#ppp multilink
Router4(config-if)#exit
Router4(config)#dialer-list 1 protocol ip permit
Router4(config)#router ospf 87
Router4(config-router)#network 192.168.15.0 0.0.0.255 area 10
Router4(config-router)#exit
Router4(config)#end
Router4#
Router1#configure terminal
Enter configuration commands, one per line.     End with CNTL/Z.
Router1(config)#username Router4 password 0 cisco
Router1(config)#interface BRI0/0
Router1(config-if)#ip address 192.168.15.1 255.255.255.0
Router1(config-if)#encapsulation ppp
Router1(config-if)#dialer-group 1
Router1(config-if)#isdn switch-type basic-ni
Router1(config-if)#isdn spid1 416555000000 4165550000
Router1(config-if)#isdn spid2 416555000100 4165550001
Router1(config-if)#ppp authentication chap
Router1(config-if)#ppp multilink
Router1(config-if)#exit
Router1(config)#dialer-list 1 protocol ip permit
Router1(config)#router ospf 87
Router1(config-router)#network 192.168.15.0 0.0.0.255 area 10
Router1(config-router)#exit
Router1(config)#end
Router1#

注释 使用ip ospf demand-circuit 的命令可以保持邻居关系一直是FULL状态,而不管链路是否激活
8.12.     路由汇总
提问 减少路由表大小
回答
Router1#configure terminal
Enter configuration commands, one per line.     End with CNTL/Z.
Router1(config)#router ospf 55
Router1(config-router)#area 100 range 172.20.0.0 255.255.0.0
Router1(config-router)#area 0 range 172.25.0.0 255.255.0.0
Router1(config-router)#area 2 range 10.0.0.0 255.0.0.0
Router1(config-router)#exit
Router1(config)#end
Router1#
注释 OSPF的路由汇总只能配置在ABR上。生成的汇总路由代价值缺省情况下和子网路由中最小的一致,也就是说汇总路由的稳定状态和代价值最小的那个路由条目相关,这也是RFC1583上的定义,在新的RFC中定义了汇总路由代价值和最大的那个路由条目相关,所以一定要确定所有路由器采用相同的计算方法,思科缺省使用RFC1583的方法,禁用可以使用no compatible rfc1583。在ABR上启用汇总以后会自动生成一条汇总路由的丢弃路由(12.1(6))来避免路由回环
8.13.     在特定端口禁用OSPF
提问 禁止某个端口参与OSPF
回答
Router3#configure terminal
Enter configuration commands, one per line.     End with CNTL/Z.
Router3(config)#router ospf 44
Router3(config-router)#network 0.0.0.0 255.255.255.255 area 100
Router3(config-router)#passive-interface Ethernet0
Router3(config-router)#exit
Router3(config)#end
Router3#
注释 OSPF也是通过配置被动接口的方式来不生成邻居关系从而避免参与OSPF。当然也可以通过不在network命令中包含此端口来禁止,下面就是另外一种很好的配置方法,network了所有接口,但是缺省所有端口是被动接口,对于需要的接口再使用no的命令才参与OSPF:
Router3(config)#router ospf 44
Router3(config-router)#network 0.0.0.0 255.255.255.255 area 100
Router3(config-router)#passive-interface default
Router3(config-router)#no passive-interface Ethernet0
Router3(config-router)#exit
Router3(config)#end
Router3#
8.14.     修改接口的网络类型
提问 修改某个端口缺省的网络类型
回答
Router9#configure terminal
Enter configuration commands, one per line.     End with CNTL/Z.
Router9(config)#interface FastEthernet0/0
Router9(config-if)#ip ospf network ?
     broadcast               Specify OSPF broadcast multi-access network
     non-broadcast           Specify OSPF NBMA network
     point-to-multipoint     Specify OSPF point-to-multipoint network
     point-to-point          Specify OSPF point-to-point network

Router9(config-if)#
注释 上述四个关键词主要定义媒介是否支持广播或者组播数据包,是否需要选举DR。对于Broadcast网络,支持组播,DR可以自动选择,不需要配置。对于nonbroadcast网络,不支持组播,必须人工使用neighbor命令配置邻居关系。对于point-to-multipoint网络,不需要DR选举,也不需要neighbor命令,这时候需要注意的是framerelay配置中要允许broadcast:
Router9(config)#interface Serial0/0
Router9(config-if)#ip address 192.168.10.9 255.255.255.0
Router9(config-if)#encapsulation frame-relay
Router9(config-if)#frame-relay map ip 192.168.10.2 123 broadcast
Router9(config-if)#ip ospf network point-to-multipoint
Router9(config-if)#exit
Router9(config)#router ospf 1
Router9(config-router)#network 192.168.10.0 0.0.0.255 area 0
Router9(config-router)#exit
否则必须配置neighbor
Router9(config)#interface Serial0/0
Router9(config-if)#ip address 192.168.10.9 255.255.255.0
Router9(config-if)#encapsulation frame-relay
Router9(config-if)#frame-relay map ip 192.168.10.2 123
Router9(config-if)#ip ospf network point-to-multipoint non-broadcast
Router9(config-if)#exit
Router9(config)#router ospf 1
Router9(config-router)#network 192.168.10.0 0.0.0.255 area 0
Router9(config-router)#neighbor 192.168.10.2
Router9(config-router)#exit
最后一种point-to-point网络不需要DR,但必须支持组播来建立邻居,否则需要配置neighbor命令。
还有一个特殊的回环地址,缺省情况OSPF会宣告回环地址为/32的网络,但是你可以在回环接口上配置其为ip ospf network point-to-point,来强制他宣告正确的网络掩码
8.15.     路由标签
提问 对特定的路由打标签避免互相再发布出现路由回环
回答
Router1#configure terminal
Enter configuration commands, one per line.     End with CNTL/Z.
Router1(config)#router ospf 55
Router1(config-router)#redistribute eigrp 11 metric-type 1 subnets tag 67
Router1(config-router)#exit
Router1(config)#end
Router1#
注释
8.16.     记录OSPF邻居状态变化
提问 记录OSPF邻居状态变化信息
回答
Router2#configure terminal
Enter configuration commands, one per line.     End with CNTL/Z.
Router2(config)#router ospf 12
Router2(config-router)#log-adjacency-changes
Router2(config-router)#exit
Router2(config)#end
Router2#
注释 12.1后对上面命令增加了detail参数可以看到更多邻居状态变化的信息
8.17.     OSPF定时器
提问 调整定时器,加快收敛
回答
Router1#configure terminal
Enter configuration commands, one per line.     End with CNTL/Z.
Router1(config)#interface Serial0/1
Router1(config-if)#ip ospf hello-interval 5
Router1(config-if)#ip ospf dead-interval 20
Router1(config-if)#exit
Router1(config)#end
Router1#
注释 要保证和此端口相连的设备采用相同的定时器值,否则邻居关系不能建立
8.18.     减少OSPF协议流量
提问 在稳定的网络要不需要LSA的过多数据包传递
回答
Router9#configure terminal
Enter configuration commands, one per line.     End with CNTL/Z.
Router9(config)#interface Serial0/0
Router9(config-if)#ip address 192.168.10.9 255.255.255.0
Router9(config-if)#ip ospf flood-reduction
Router9(config-if)#exit
Router9(config)#end
Router9#
注释 正常情况下OSPF会每隔一小时进行所有的LSA泛洪,在稳定网络里面一般不需要,所以通过这种方式设定LSA的DoNotAge位,避免过多流量
8.19.     OSPF虚拟链路
提问 把两个分开的路由器通过虚拟链路的方式相连
回答
Router9#configure terminal
Enter configuration commands, one per line.     End with CNTL/Z.
Router9(config)#router ospf 1
Router9(config-router)#area 10 virtual-link 10.54.0.1
Router9(config-router)#exit
Router9(config)#end
Router9#
注释 通过show ip ospf virtual-links来验证。需要注意的是这个需要两个路由器都进行配置,IP地址是对方的Router ID,要确保这个地址是通的,area后面跟的是穿越的Area
8.20.     使用域名查看OSPF状态
提问 在OSPF的show命令中现实设备域名而不是地址
回答
Router3#configure terminal
Enter configuration commands, one per line.     End with CNTL/Z.
Router3(config)#ip ospf name-lookup
Router3(config)#end
Router3#
注释 无
8.21.     OSPF排错
提问 对OSPF进行排错
回答
Router3#debug ip ospf adj
OSPF adjacency events debugging is on
Router3#
注释 OSPF排错命令很多,这里只提供了对邻居关系的排错命令,因为邻居是OSPF的基础

OSPF发布缺省路由

No Comments CISCO ,

在册子岛调试网络,使用show ip route时不能学到缺省路由,因为 redistribute static subnets只能公布非缺省的静态路由。
OSPF如何产生缺省路由?
1、default-information originate
?? 用途:使ospf能广播缺省路由0.0.0.0 到ospf域内。如果路由0.0.0.0 在本地ip路由选择表中存在,该命令才能广播路由,如果不存在,当然就不能广播了。

1、 default-information originate always

用途:使ospf能广播缺省路由0.0.0.0 到ospf域内,即使路由0.0.0.0 在本地ip路由选择表中不存在,该命令形式也会广播缺省路由。如果关键词always没有被使用,并且缺省路由是抖动(flapping)的,那么ospf需要在每次缺省抖动时,向ospf域发送更新。如果缺省路由是抖动的,使用关键词always将减少对ospf数据库的操作,保持ospf数据库的稳定。
2、? default-information originate metric cost

3、? default-information originate always metric cost

Cost——被广播的外部缺省路由的度量(metric)成本,其值范围是0~1677214
用途:用来设置乡ospf域广播的缺省路由的外部成本。命令的第一种形式只有路由存在于本地ip路由选择表中时才广播缺省路由。第二种形式无条件的广播缺省路由。如果不止ospf路由器广播缺省路由,度量(meitric)能被用来选择较佳缺省路由。具有最低度量(meitric)的缺省路由被认为是最佳路由。
4、? default-information originate metric-type type

5、? default-information originate always metric-type type
type——类型可设为1或2。类型1路由的成本包括再次分布路由的外部成本和ospf成本。类型2路由的成本只能包括外部成本。缺省是类型2
用途:当路由被再次分布到ospf中时,路由会被分配到一个表示从ASBR到这个路由的成本的度量。如果缺省路由作为类型2路由(缺省情况)进行广播,那么缺省路由的成本在ospf域内的每台路由器都应该是1。如果缺省路欧作为类型1路由进行广播,那么缺省路由的成本将包括到达ASBR的内部成本和被ASBR设置的路由的外部成本。如果在ospf域内存在多条到达ASBR的路径,那么在作为类型2广播时,所有路由都将具有相同的成本。如果缺省路由作为类型1路由广播,那么ospf可以确定到达ASBR的最佳路径。
6、? default-information originate route-map route-map-name

route-map-name——只在满足route-map的条件时,ospf才会产生缺省路由。如果使用关键词always,缺省路由将被广播,而不管route-map的条件限制
用途:缺省路由的广播可使用route-map有条件的实现。如果满足route-map的条件,缺省路由会被广播到ospf域内。

OSPF Trouble 集锦 排错 详解

No Comments CISCO ,

 

                 r1–e0/0———————e0/0       —–r2

         e0/1     |

                  |       e0/1

                   r3

r1:

interface Ethernet0/0
ip address 10.10.13.1 255.255.255.0
half-duplex
end

interface Ethernet0/1
ip address 10.10.31.1 255.255.255.0
half-duplex
end

router ospf 10
router-id 10.10.3.3
log-adjacency-changes
network 10.10.13.1 0.0.0.0 area 0
network 10.10.31.1 0.0.0.0 area 0

r2

interface FastEthernet0/3
no switchport
ip address 10.10.13.2 255.255.255.252
end

router ospf 10
router-id 10.10.7.7
log-adjacency-changes
network 10.10.7.7 0.0.0.0 area 0
network 10.10.13.2 0.0.0.0 area 0

r3

interface FastEthernet0/3
no switchport
ip address 10.10.31.2 255.255.255.252
end

router ospf 10
router-id 10.10.8.8
log-adjacency-changes
network 10.10.31.2 0.0.0.0 area 0
network 10.10.43.1 0.0.0.0 area 43

现像

r1

#show ip ospf nei

Neighbor ID          Pri        State                Dead Time        Address              Interface

r2#show ip ospf nei

Neighbor ID          Pri        State                Dead Time        Address              Interface

r3#show ip ospf nei

Neighbor ID          Pri        State                Dead Time        Address              Interface

本题OSPF 邻居起不来 是因为掩码不一致

oSPF 区域验证 area area-id authentication

No Comments CISCO ,

OSPF 区域验证 area area-id authentication

配置简单AREA验证

step1 接口下配置 验证所需的KEY

           ip ospf authentication-key cisco

ip ospf message-digest-key 1 md5 ciscoac   //启用MD5 KEY

step2    在OSPF进程下开启验证

router ospf 1
             area 0 authentication //启用简单验证

area 0 authentication message-digest   //启用MD5加密验证

setp3      查看验证是否开启

                show ip ospf  

rtrA#show ip ospf
Routing Process "ospf 1" with ID 1.1.1.1
      Area BACKBONE(0)
          Number of interfaces in this area is 2
        Area has simple password authentication

Router A
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Serial0/0
ip address 10.1.1.9 255.255.255.252
ip ospf authentication-key cisco
!
interface Serial0/1
ip address 10.1.1.1 255.255.255.252
ip ospf authentication-key cisco
clock rate 64000
!
router ospf 1
area 0 authentication
network 10.1.1.0 0.0.0.15 area 0
_______________________________________________________________________
Router B
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Serial0
ip address 10.1.1.2 255.255.255.252
ip ospf authentication-key cisco
!
interface Serial1
ip address 10.1.1.5 255.255.255.252
ip ospf authentication-key cisco
clock rate 64000
!
router ospf 1
area 0 authentication
network 10.1.1.0 0.0.0.15 area 0
_______________________________________________________________________
Router C
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Serial0
ip address 10.1.1.6 255.255.255.252
ip ospf authentication-key cisco
!
interface Serial1
ip address 10.1.1.10 255.255.255.252
ip ospf authentication-key cisco
clock rate 64000
!
router ospf 1
area 0 authentication
network 10.1.1.0 0.0.0.15 area 0

OSPF 虚链路验证 Authentication Over a Virtual Link

No Comments CISCO ,

 

配置虚链路验证

setp1 接口下配置KEY

ip ospf authentication-key cisco

setp2 ospf进程下开启认证

             router ospf 1
             area 0 authentication

setp3 在虚链路下开启认证

            area 1 virtual-link 3.3.3.3 authentication-key bosco

setp4      查看是否成功

              show ip ospf

EX1 使用简单验证

Router A
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Serial0/1
ip address 10.1.1.1 255.255.255.252
ip ospf authentication-key cisco
clockrate 64000
!
router ospf 1
area 0 authentication
network 10.1.1.0 0.0.0.3 area 0
network 1.1.1.1 0.0.0.0 area 0

Router B
router ospf 1
area 0 authentication
area 1 virtual-link 3.3.3.3 authentication-key bosco // 这个KEY 和前面接口下的KEY没有关系

**********************************************************************************************

Router(config-router)#area 1 virtual-link 3.3.3.3 authentication-key ?
      <0-7>      Encryption type (0 for not yet encrypted, 7 for proprietary)
  LINE       Authentication key (8 chars) //这个KEY 和前面接口下的KEY没有关系

**********************************************************************************************

network 2.2.2.2 0.0.0.0 area 0
network 10.1.1.0 0.0.0.3 area 0
network 10.1.1.4 0.0.0.3 area 1
_______________________________________________________________________
Router C
router ospf 1
area 0 authentication  

*****************************************************************************

注意: Notice that the command area 0 authentication was used on Router C because the virtual link is in Area 0.

         如果在area0 RA 上开启了验证 那么在 在RC 上也要使用 area 0 authentication 命令,因为RC通过virtual-link连接到了 area 0

****************************************************************

EX2      配置MD5 验证

Message Digest Authentication Over a Virtual Link

Router B
router ospf 1
area 1 virtual-link 3.3.3.3 authentication message-digest
area 1 virtual-link 3.3.3.3 message-digest-key 1 md5 cisco

network 2.2.2.2 0.0.0.0 area 0
network 10.1.1.0 0.0.0.3 area 0
network 10.1.1.4 0.0.0.3 area 1
_______________________________________________________________________
Router C
router ospf 1
area 1 virtual-link 2.2.2.2 authentication message-digest   //启用MD5认证
area 1 virtual-link 2.2.2.2 message-digest-key 1 md5 cisco //设MD5KEY-1 为 cisco

network 3.3.3.3 0.0.0.0 area 2
network 10.1.1.4 0.0.0.3 area 1

验证:


rtrB#show ip ospf virtual-links
Virtual Link OSPF_VL3 to router 3.3.3.3 is up     //VIR状态
     Run as demand circuit
     DoNotAge LSA allowed.
     Transit area 1, via interface Serial1, Cost of using 64
     Transmit Delay is 1 sec, State POINT_TO_POINT,
     Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
       Hello due in 00:00:01
       Adjacency State FULL (Hello suppressed)
  Message digest authentication enabled         //此句说明MD5 验证已经启用
    Youngest key id is 1                                   //说明的KEY-1

Configuration Example : Null Authentication    不启用VIR验证

Router B
router ospf 1
area 0 authentication
area 1 virtual-link 3.3.3.3 authentication null
network 2.2.2.2 0.0.0.0 area 0
network 10.1.1.0 0.0.0.3 area 0
network 10.1.1.4 0.0.0.3 area 1
_______________________________________________________________________
Router C
router ospf 1
area 1 virtual-link 2.2.2.2 authentication null
network 3.3.3.3 0.0.0.0 area 2
network 10.1.1.4 0.0.0.3 area 1

OSPF排错

No Comments CISCO ,

OSPF 邻居起不来之掩码错误

r4#
r4#clear ip ospf p
Reset ALL OSPF processes? [no]: y
r4#
r4#
r4#
r4#
r4#
r4#
*Mar 1 02:40:14.279: OSPF: Flushing External Links
*Mar 1 02:40:14.279: OSPF: Flushing Opaque AS Links
*Mar 1 02:40:14.319: OSPF: Flushing Link states in area 0
*Mar 1 02:40:14.327: OSPF: Send hello to 224.0.0.5 area 0 on Serial0 from 9.9.11.4
*Mar 1 02:40:14.355: OSPF: Interface Serial0 going Down
*Mar 1 02:40:14.355: OSPF: Neighbor change Event on interface Serial0
*Mar 1 02:40:14.359: OSPF: DR/BDR election on Serial0
*Mar 1 02:40:14.359: OSPF: Elect BDR 0.0.0.0
*Mar 1 02:40:14.363: OSPF: Elect DR 0.0.0.0
*Mar 1 02:40:14.363:        DR: none    BDR: none
*Mar 1 02:40:14.571: OSPF: Interface Serial0 going Up
r4#
r4#
r4#
r4#
r4#
r4#
r4#
*Mar 1 02:40:14.571: OSPF: Send hello to 224.0.0.5 area 0 on Serial0 from 9.9.11.4
r4#
*Mar 1 02:40:15.851: OSPF: Rcv hello from 9.9.1.1 area 0 from Serial0 9.9.11.1
*Mar 1 02:40:15.855: OSPF: Mismatched hello parameters from 9.9.11.1
*Mar 1 02:40:15.859: OSPF: Dead R 40 C 40, Hello R 10 C 10 Mask R 255.255.255.0 C 255.255.255.248
r4#
*Mar 1 02:40:24.579: OSPF: Send hello to 224.0.0.5 area 0 on Serial0 from 9.9.11.4
r4#
*Mar 1 02:40:25.759: OSPF: Rcv hello from 9.9.1.1 area 0 from Serial0 9.9.11.1
*Mar 1 02:40:25.763: OSPF: Mismatched hello parameters from 9.9.11.1
*Mar 1 02:40:25.767: OSPF: Dead R 40 C 40, Hello R 10 C 10 Mask R 255.255.255.0 C 255.255.255.248
r4#
*Mar 1 02:40:34.583: OSPF: Send hello to 224.0.0.5 area 0 on Serial0 from 9.9.11.4
r4#
*Mar 1 02:40:35.759: OSPF: Rcv hello from 9.9.1.1 area 0 from Serial0 9.9.11.1
*Mar 1 02:40:35.763: OSPF: Mismatched hello parameters from 9.9.11.1
*Mar 1 02:40:35.767: OSPF: Dead R 40 C 40, Hello R 10 C 10 Mask R 255.255.255.0 C 255.255.255.248
r4#
*Mar 1 02:40:44.587: OSPF: Send hello to 224.0.0.5 area 0 on Serial0 from 9.9.11.4
r4#
*Mar 1 02:40:45.759: OSPF: Rcv hello from 9.9.1.1 area 0 from Serial0 9.9.11.1
*Mar 1 02:40:45.763: OSPF: Mismatched hello parameters from 9.9.11.1
*Mar 1 02:40:45.767: OSPF: Dead R 40 C 40, Hello R 10 C 10 Mask R 255.255.255.0 C 255.255.255.248
r4#
*Mar 1 02:40:54.571: OSPF: end of Wait on interface Serial0
*Mar 1 02:40:54.571: OSPF: DR/BDR election on Serial0
*Mar 1 02:40:54.575: OSPF: Elect BDR 0.0.0.0
*Mar 1 02:40:54.575: OSPF: Elect DR 0.0.0.0
*Mar 1 02:40:54.579:        DR: none    BDR: none
*Mar 1 02:40:54.591: OSPF: Send hello to 224.0.0.5 area 0 on Serial0 from 9.9.11.4
r4#
*Mar 1 02:40:55.759: OSPF: Rcv hello from 9.9.1.1 area 0 from Serial0 9.9.11.1
*Mar 1 02:40:55.763: OSPF: Mismatched hello parameters from 9.9.11.1
*Mar 1 02:40:55.767: OSPF: Dead R 40 C 40, Hello R 10 C 10 Mask R 255.255.255.0 C 255.255.255.248
r4#
*Mar 1 02:41:04.595: OSPF: Send hello to 224.0.0.5 area 0 on Serial0 from 9.9.11.4
r4#
*Mar 1 02:41:05.759: OSPF: Rcv hello from 9.9.1.1 area 0 from Serial0 9.9.11.1
*Mar 1 02:41:05.763: OSPF: Mismatched hello parameters from 9.9.11.1
*Mar 1 02:41:05.767: OSPF: Dead R 40 C 40, Hello R 10 C 10 Mask R 255.255.255.0 C 255.255.255.248
r4#
*Mar 1 02:41:14.599: OSPF: Send hello to 224.0.0.5 area 0 on Serial0 from 9.9.11.4
r4#
*Mar 1 02:41:15.759: OSPF: Rcv hello from 9.9.1.1 area 0 from Serial0 9.9.11.1
*Mar 1 02:41:15.763: OSPF: Mismatched hello parameters from 9.9.11.1
*Mar 1 02:41:15.767: OSPF: Dead R 40 C 40, Hello R 10 C 10 Mask R 255.255.255.0 C 255.255.255.248
r4#
*Mar 1 02:41:24.603: OSPF: Send hello to 224.0.0.5 area 0 on Serial0 from 9.9.11.4
r4#
*Mar 1 02:41:25.759: OSPF: Rcv hello from 9.9.1.1 area 0 from Serial0 9.9.11.1
*Mar 1 02:41:25.763: OSPF: Mismatched hello parameters from 9.9.11.1
*Mar 1 02:41:25.767: OSPF: Dead R 40 C 40, Hello R 10 C 10 Mask R 255.255.255.0 C 255.255.255.248
r4#
*Mar 1 02:41:34.607: OSPF: Send hello to 224.0.0.5 area 0 on Serial0 from 9.9.11.4
r4#
*Mar 1 02:41:35.775: OSPF: Rcv hello from 9.9.1.1 area 0 from Serial0 9.9.11.1
*Mar 1 02:41:35.779: OSPF: Mismatched hello parameters from 9.9.11.1
*Mar 1 02:41:35.779: OSPF: Dead R 40 C 40, Hello R 10 C 10 Mask R 255.255.255.0 C 255.255.255.248
r4#

调速OSPF SPF TIMES

No Comments 网络技术

 

r1(config)#router ospf 10
r1(config-router)#timers throttle spf 10     1000           5000
                                     10开始 第一次调速阀值 最大
r1#sh ip ospf
Routing Process "ospf 10" with ID 11.1.1.1
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Supports area transit capability
Initial SPF schedule delay 10 msecs
Minimum hold time between two consecutive SPFs 1000 msecs
Maximum wait time between two consecutive SPFs 5000 msecs

排除OSPF故障

No Comments CISCO ,

 

1.不匹配的参数

使用debug ip ospf adj命令能够看到大多数的不匹配问题。

(1)hello/dead间隔不匹配——匹配才可以形成邻居。

(2)不匹配的认证类型——OSPF下有MD5和纯文本认证。

router ospf 1

area 0 authentication message-digest

network x.x.0.0 0.0.255.255 area 0

(3)不匹配的区域ID——区域信息在OSPF的HELLO分组中发送。不同,不会形成邻接。

(4)不匹配的短截/传输/NSSA区域选项——当OSPF与一个邻居交换HELLO分组时,它所交换的一项内容是由8比特表示的可选能力。选项字段之一是E比特,即OSPF短截标志。当E比特置0时,该路由关联的区域是一个短截区域,外部LSA不允许进入这个区域。

2.OSPF状态问题

成为邻居的路由器不保证交换链路状态更新。一旦路由器决定与一个邻居形成邻接,它就开始交换其链路状态数据库的一份完整拷贝。

(1)OSPF陷入ATTEMPT——仅对neighbor语句的NBMA网络有效。陷入ATTEMPT是指一台路由器试图通过发送它的HELLO来联系邻居但是它没有收到响应。

show ip ospf neighbor查看。

原因:错误配置neighbor;NBMA上的单播连通性断了,这可能是由错误的DLCI,访问列表或转换单播的NAT引起的。

(2)OSPF陷入INIT——INIT状态表示路由器收到来自邻居的HELLO分组,但是双向通信并没有建立 .

原因:

。 一方访问列表阻止了HELLO;

。 一方的多播能力失效(一个交换机故障);

。 仅在一方启用了认证;

。 一方的frame-relay map/dialer map语句缺少了broadcast关键字。

。 一方的HELLO在第2层丢失了。

(3)OSPF陷入2-WAY——双向状态是指路由器在HELLO分组的邻居字段中见到了自己的路由器ID.类似于所有路由器的优先级都为0,则不会发生选举,所有路由器停留在双向状态中。

解决:确保至少一台路由器具有一个至少为1的IP OSPF优先级。

(4)OSPF陷入EXSTART/EXCHANGE——在EXSTART或EXCHANGE状态的OSPF邻居正处于尝试交换DBD(数据库描述)分组的过程中。

原因:

。 不匹配的接口MTU

。 邻居上重复的路由器ID

。 无法用超过特定MTU 长度进行PING

。 断掉的单播连通性,它可能是因为错误的DLCI,访问列表或转换单播的NAT

(5)OSPF陷入LOADING——邻居没有应答或邻居的应答从未到达本地路由器,路由器也会陷入LOADING状态。常有"%OSPF-4-BADLSA"控制台信息。

原因:

。 不匹配的MTU

。 错误的链路状态请求分组

3.点到点链路的一方是无编号的

interface s0

ip unnumbered loopback0

解决:双方都需要成为一个有编号点到点链路或一个无编号点到点链路。

4.ABR没有产生一个类型4的汇总LSA

类型4的汇总LSA的一个功能是宣告到其他区域的ASBR的可达性。如果同一个区域中存在ASBR则不需要类型4的LSA.

show ip ospf database external 命令的输出显示在路由器的外部OSPF数据库中是否存在路由。

show ip ospf database asbr-summary 命令的输出显示路由是否有类型4的LSA.

检查R是否真是ABR.如果是,则产生类型3或类型4的汇总LSA.show ip ospf

5.转发地址不能通过区域内或区域间路由获知

当OSPF获得一条外部LSA时,它在将该路由装入路由选择表之前要确定转发地址可通过一条OSPF区域内或区域间路由获知。如果转发地址不能通过区域内或区域间路由获知,OSPF不会将路由装入路由选择表中。

有可能的解决:

。 不在ABR上进行汇总

。 在ASBR上过滤再分布入OSPF中的直接子网

router ospf 1

redistribute rip subnets

6.路由汇总问题

两种类型汇总:

。 可执行在ABR上的区域间路由汇总

。 可执行在ASBR上的外部路由汇总

(1)区域间汇总

router ospf 1

area 3 range x.x.x.0 255.255.255.0

通过show ip ospf可以查看

(2)外部汇总

router ospf 1

summary-address x.0.0.0 255.0.0.0

7.CPUHOG问题

产生在:。 邻居形成过程

。 LSA刷新过程

8.SPF计算和路由翻动

只要拓扑有变化,OSPF就运行SPF算法再次计算最短路径优先树。,可能引起链路的不稳定。

原因:。 区域内的接口翻动

。 区域内的邻居接口翻动

。 重复的路由器ID

使用show ip ospf命令可查看在一个给定区域中SPF算法运行的次数;

使用debug ip ospf monitor来隔离一个翻动的LSA;

使用show log命令显示由接口引起的翻动。

解决:

。 修复正在翻动的链路

。 重新定义区域边界

ISIS OSPF 双向重发布

R1—-ISIS&OSPF—–R2

r1#sh run
Building configuration…

Current configuration : 1558 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
clns routing
frame-relay switching
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.10.1.1 255.255.255.0
ip router isis
!
interface Loopback10
no ip address
!
interface Loopback100
ip address 111.111.111.111 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/1
ip address 1.1.12.1 255.255.255.0
ip router isis
encapsulation frame-relay
ip ospf network point-to-point
serial restart-delay 0
clock rate 64000
clns router isis
frame-relay map ip 1.1.12.2 102 broadcast
frame-relay map clns 102 broadcast
no frame-relay inverse-arp
frame-relay intf-type dce
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router ospf 10
log-adjacency-changes
redistribute isis level-2 subnets
network 1.1.12.1 0.0.0.0 area 0
network 111.111.111.111 0.0.0.0 area 0
!
router isis
net 49.1111.1111.1111.00
is-type level-2-only
metric-style wide
redistribute ospf 10 metric 100
!
ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!        
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end

r2#sh run
Building configuration…

Current configuration : 1432 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
clns routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback10
ip address 11.11.2.2 255.255.255.0
ip router isis
!
interface Loopback11
ip address 222.222.222.222 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
ip address 1.1.12.2 255.255.255.0
ip router isis
encapsulation frame-relay
ip ospf network point-to-point
serial restart-delay 0
clock rate 64000
clns router isis
frame-relay map ip 1.1.12.1 102 broadcast
frame-relay map clns 102 broadcast
no frame-relay inverse-arp
!        
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router ospf 10
log-adjacency-changes
redistribute isis level-2 subnets
network 1.1.12.2 0.0.0.0 area 0
network 222.222.222.222 0.0.0.0 area 0
!
router isis
net 49.1111.2222.2222.00
is-type level-2-only
metric-style wide
redistribute ospf 10 metric 100
!
ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!        
line con 0
line aux 0
line vty 0 4
!
!
end